Download

Freeze on Play - Too many meshes?

Hey all. While building a city I needed to build a dock. To build it, i used many planks and board meshes placed together to give the appearance of a wooden structure. I used the same technique and assets found in the Ocean Shader/ Weather Community project here on the forums. I hadn’t run into any problems since I built the dock, but now I simply can’t play or simulate in the editor, it just freezes. The editor runs just fine with this many meshes in the scene, so I’m looking for some advice. I tried placing a culling volume with a few different settings. I know its working as expected because when I toggle “game view” the dock culls as expected, but I still can’t seem to play the scene.

I’d like to find a solution or work around to this issue before resorting to acquiring new dock assets. Thanks!

Bump. Tried deleting all the meshes and it seems to play. But it seems whenever I have a large number of static meshes in the scene it just refuses to play. I definitely need a solution to test environments with large quantities of objects like cities and towns.

-what happens when you try to play it in standalone?
-what happens when you “simulate” the game?
-how many tris and drawcalls do you have in your scene?
-what are your specs?
-which engine version? :slight_smile:

It freezes whether I play in editor, standalone, simulate, or new editor window.
I have a bit over 2 million triangles, but I have a culling volume that limits just about any sized object to be culled after 5 meters for testing purposes only
The average mesh draw calls in the entire scene is about 1000
I have 2x gtx 970 in SLI (although I don’t think UE4 takes advantage of SLI), an i5 4690k cpu, 32gb ram
Engine version 4.9

Still having issues with this. It seems that UE4 just won’t play with a large number of individually placed meshes in the scene. I had no problems running scenes with hundreds upon hundreds of high poly foliage/tree assets from the Kite Demo. Even after getting rid of the dock, I still can’t play the game in the editor or standalone when a large number of walls (100 or so) are placed.

How long are you leaving it before you consider it frozen? It may just be taking some time to load. I have a similar system to yours, and I have on avg somewhere between 6 - 11 million triangles in my scene and I am able to play in PIE. Sometimes it can take some time to load in all the assets before it lets me play, but it never completely freezes.

Did you ever try deleting stuff in your scene in chunks until it stops freezing? Maybe a specific asset is causing the freeze and it doesn’t even have anything to do with the poly count / mesh count.

I let it load over night to be certain, came back and it was just a black, unresponsive screen. Other times I gave it a couple of hours to load. Its quite frustrating, as I feel that I need to fix this issue before I continue the scene or I’ll end up putting a lot of work into something that won’t play.

Yep. First I tried deleting all of the wood piece for the dock and it still wouldnt load. So I started deleting wall segments. Eventually I was able to get it to play, but only with a portion of what I needed for the scene.

I think I’m going to try a fresh project and see if I can replicate the issue. I’m using some walls/tower assets from Infinity Blade and other assets from the Ocean and Weather Community project.

lol. Need to think about the average individual gamer and what they will be using. You got the state of the art gamer god cpu and if that is boggin down then that should tell you somethin,lol. Like production of a webpage who will be your audiance and what percentage will have top grade cpu or graphicscards. Look at Minecraft. Notmuch visually but he didnt go home broke either.

I don’t think you fully understand the problem. There is no performance dip. In editor, the scene runs well over 100 fps. But when I try to play the game, the editor simply freezes like something is hanging it up.

After testing this in another project, I haven’t been able to reproduce the issue. I placed many times more dock pieces in the new project than existed in my own, with no problem whatsoever loading PIE. At a loss.
EDIT: Ok. So I’m using a world composition map, and for some reason even though all levels were assigned to the default Uncategorized category with the default 50,000 unit streaming distance, all of my terrain bits were being loaded at once without LOD’s. Not sure why that happened, but I made a new category and now it seems I can PIE with all of my meshes loaded in. I’ll keep testing to verify this was the problem.