Freeze at 75% while importing fbx file

I had downloaded one vehicle model from here ://tf3dm/3d-model/vab-3010-56851.html . The model is of 60 mb but still whenever I import it ue4 just freezes at 75%. I even leave ue4 alone for 1-2hrs but still the model doesn’t gets imported.

My PC Specs
12 GB Ram

Amd A8

Operating System
Windows 10 Pro Technical Preview 64-bit
AMD Radeon HD 8550G + HD 8500M Dual Graphics

How much triangles your model have?

60 mb files can take a while till they are imported -> make sure to disable “import texture” + “create material”. :slight_smile:

There are 717363 polygons, 416 objects, 722164 points

But I need the textures and materials inside of the model

But you can import them separately :wink: -> import the texture - right click on it - create material - assign it to your mesh

If you import all object at once that can take a long time.

The mesh is too complex, it’s not designed for games

:o… There I thought 200k polys for a character was too many… It is though right? Lol…

10k - 20k triangles is what most game characters have I think.

Sorry to hijack that the thread a sec but. Say I have a character between 150-200k polys/triangles(sorry I’m not sure, I’m a real beginner at modelling)… Realistically, is there a way reduce characters count by 10times? I’ve tried using that tool (which I forget the name of) in blender, and got the model down to 50k before it started to alter the appearance. But as soon as I apply the texture the model came with, blender freezes :confused: my rig isn’t the best for modelling I must say, I built it originally for gaming so I don’t know if this is the reason.

You can reduce the tri count without losing quality when you bake normal/ao/… maps out of your high poly mesh. After that reduce your tri count by hand (the modifiers are not perfect) :slight_smile:

I havent watched the entire video, but probably it’s useful for your: ?v=ApzVWuPa4A4

If you really want to insist to put that model into Unreal then just wait a bit longer. One day I just waited an entire night to get a high poly model into engine. It was stuck at %75 and in the end engine got it. So just wait. It was a city model. But I suggest you to modify your model.

If you really need to put high poly models into Unreal Engine you’re going to need to split it up first.
What I do in 3ds is assign pieces to groups and export them out individually (no larger then 10mb FBX files).
Then when importing them into Unreal Engine, just make sure you move them all into the same X,Y,Z location and it should fit together like a puzzle :slight_smile:

yeah. i tried the stingray engine only 1 minute

While I’m stuck at 75 lol

That is quite a large amount, to be honest. I would suggest breaking this down into a number of meshes. It is hard to tell much without an example of the model, but if this is a building or similar, then it would be wise to opt for a modular work-flow. A 60mb model is rather large, in terms of file size. It will undoubtedly be able to be imported…but it is understandable that it will take a fair amount of time.

Each engine handles things differently. You can’t compare one to another in that way, I’d say. If you’re having problems importing a model, there is likely a reason for it. Similar to what I’ve said above, your model will no doubt be able to be imported…you’ll simply have to wait. This will all depend on your machine, processing power, and so forth, as well.

I’m glad this thread exists. It answered my exact same question. I just put a 60mb mesh into the engine and it is taking a while. I closed it once, then reopened to try again. I’ll wait a few hours I guess. Would it really take hours? anyways, on a side note, my mesh is a dude without eyeballs, (no reason, just haven’t gotten to it and just messing around with the engine) Do the meshes need to be closed or can there be openings like a big hole where the eyes should be?

I had this same problem once with a Lamborghini FBX file that I was trying to import, but I left it on over the whole night and in the morning when I checked it was done. I know you might not consider this a good idea but at least it worked for me.

I had the same problem, however when I used file/import into level it worked fine.
Only had to wait for 5 minutes or so to be finished.

Well, they could at least have something like daz3d bridge to Unity when porting files, that bridge shows every file as it is being converted from the DTU file, Daz3D will create a DTU & FBX file with the complied textures & materials if you have selected to import them with the model, here is what I’m saying in a picture.

It lists the files as it converts them so you can see what exact files the process is working on something Unreal lacks when porting in files for the editor to convert, you get this hang on a percent can’t see what’s happening so you end task with control alt delete because it seems the process never finishes it just hangs on a certain percent where older versions of Unreal never done that they at least finished file conversion…
If it’s the high poly count that is taking so long than why is it different for the same model, one model hangs in some kind of not responding mode while the other moves to finish the render of the conversion, here i have exported a model from daz3d to Unreal 5.2.1 but this model hangs at 58% for ages.

I have already loaded two models in of the same type with different textures but the same model yet 2 have just hung at 58% while two worked in a reasonable time.
If i now just close UE down than resend the model it will usually port, could it be low memory because i previously ported one and it’s memory cache hasn’t refreshed or something?