Frames render with missing level geometry when moving quicky through level.

These are two frames taken back to back when coming around a corner. As you can see, there is geometry missing that suddenly “pops” into place. What’s going on with this, and how can I prevent it? It really takes away from the experience.

First Frame: (Missing the wall)

Second Frame: Wall is suddenly there now.

I really don’t know where to post this, so I’m posting it here. If there’s another place where I should be posting it, let me know.

I should also mention that my level layout is created via a C++ class, then completely spawned at runtime (before gameplay starts, not as gameplay is progressing) from Blueprints.

If there are any questions about the way the level is generated that need to be clarified, please let me know. I had to be pretty brief as I have to head out for about 30 minutes, but I’ll be back to check up on this. Really hoping there’s a simple answer, and a simple setting that needs changing.

The levels don’t really get all that huge as far as meshes go, and so optimizations that may be causing this probably don’t even need to be there. I just don’t no where to look for this.

-Marc

I disabled the Occlusion from the project settings, and things are working good now for me.

Thats a nice tip! Ill keep that in mind!