Frames drop by half on ndisplay in incameravfx

I use ndisplay for incameravfx. Synchronizing the signals using the sync generator and Quadro sync ii confirmed that the synchronization between the PCs was consistent, but all frames were dropped in half.
1080 24p > 12p
1080 29.97p > 15p
720 60p > 30p

This is it.

UE4.27.2 Using
cpu amd Threadripper
GPU A6000 x 2 and nvlink
Quadro sync ii

ndisplay render sync policy type nvidia
nvidia driver v-sync on follow Quadro sync ii document

I tested it using the incamera vfx base level to get rid of the heaviness of the level.
Currently, I have tested output cable replacement, monitor replacement, sync generator change, nvlink removal, reinstalling GPU driver using DDU (472.47, 472.98), reinstalling Windows, and initializing the system, but still the same symptoms are shown. Can anyone please help?

1 Like

Hey, I have the same issue with all framerates below 48 Hz. 48 or above is alright. I tried both external sync and internal from the Nvidia control panel - >Synchronize.

1 Like

Solved the issue with setting the custom resolution from nVidia control panel to 3840 x 2160.

1 Like

Thank you
I solved it with the monitor’s resolution and edid settings. I’ve come to realize that it’s not necessarily a PC specific issue.

Would you mind sharing what changed have you done to your edid that get it to work for you? Or if you’d u could share your edid - that would be even better :slight_smile:
I have 30Hz running smooth with no errors but can’t get 24hz to work. I am getting half frame rate.
Systems similar to yours: threadripper cpu, dual A6000 and Quadro sync card.
We have external house clock and a lot of AV equipment down the line of LED Processors but can’t get this 24Hz issue resolved.

Thanks in advance

HI Maciej.Zaremba

I had an intermediate device between the LED and UE4’s pc, so I was able to set the EDID separately on that device. Do you have the same equipment as above? I think there is something about setting EDID like Anything

If you want to share edid in Nvdia, I can do it. But I don’t think it’ll work because it’s not the same environment.

Thanks for your response.

Our LED redner nodes go directly to LED Processors but we are using EDID file loaded into nVidia Control panel and I get 24Hz in Stage monitor just fine but we get ocasonal frame drop which for VP is a no go … so I am still trying to come up with version of EDID that will give me smoth 24Hz rather then “most of the time”.

If you can export your EDID and share it with me , I could at least compare my settings to yours and find that missing settings so that no frames are dropped. Feel free to DM me rather then posting in here if you don’t want your EDID to be visible to anyone :slight_smile:

Thanks again

Hi Maciej

Have setting that custom Resolution resolved your issue without having to edit EDID file?
I have custom resolution created thanks to EDID and using online frequency calculator which allowed me to get 24Hz however still getting occasional frame dropping and I want it to have it really smooth with no dropouts (for Virtual Production using 4+ LED Render nodes).

Intrested to know have you managed to get it working with Sync Policy 2 and 24Hz ?

Dzieki :slight_smile:

Hi Maciej.Zaremba

I sent you “edid” but there is no message, did you receive it? I’m so sorry I’m late.

I want to continue this thread. None of the above (Even EDID) solved our issues. We are still having frame drops occasionally between every 1-3 seconds. We cant achieve genlock, this is for normal PC screens tough

Hi Xvision_Dev1

Does it mean that the sync generator and Quadro sync ii are not genlocked?

We have tried internal timing (Without genlock, but daisy chained)
We have tried with genlock signal (Daisy chain) + We have tried direct genlock.
We have also tried mosaic on only one render node, which works fine, if you disconnect ndisplay listener.

At this point, we have no clue why we are experiencing stuttering (Frame drops) occasionally every 1-3 seconds.

To answer your question, the system topology inside the nvidia controlpanel says its genlocked + framelocked.

Just to point that out. This thread is about loosing frames consistently. If you only loose a single frame every now and then it’s either caused by content being to intensive. I’ve found that especially with Lumen there can be spikes so you have to optimize scenes more.

Or you run into a similar problem as I’ve outlined here:

1 Like