Frames between Frames in persona? How to get of?

Is there a way to stop the interpolation that happens between frames in persona? I have a 3 frame anim of a bow string release, a one frame release time basically with a one frame vibration. It needs to be sharp and fast but I’m getting a smooth slow animation because of the extra frames that are added. Is there a ‘make linear’ option that I’m not seeing?

No way to change this?

As far as I know you can’t change the interpolation. But that’s not really the issue, it’s more about time, how long is the animation and if it’s too long, then make it shorter by speeding it up in the engine. Considering it’s already only one frame in frame count, you can’t make it less frames, so just speed up in the engine.

I haven’t experimented with animation timings much, like if you animate at 30fps in Max, what’s the difference compared to 15fps, or whatever. But with that said I do everything at 30fps, which is Max’s default and whatever doesn’t feel right, just tweak it either in Max or change speed in UE. But 30 seems to translate pretty good. Whether it’s 1:1, I’m not sure, I haven’t studied the timings to that degree, but it doesn’t matter much because you can so easily change the speed in engine.

Sounds more like an ease in ease out. Are you using the animation raw or in combination with a blend space or Montage? If so just look in the details panel and make them 0 and that should make it snap

If raw it could be a conversion issue from going from one frame rate to another but either way no need to re-time it as you can change the “Rate Scale” directly on the clip. Go from default 1 to say a 2 it’s forced to be twice as fast.

Thanks for the help guys.

I’ve adjusted the play rate of the animation inside the state but I can only seem to slow it down, anything over 1 doesn’t make a difference in speed.

Raw I think, as I have them set up in a state machine similar to the jump tutorials. So I can adjust play rate per animation as mentioned above but not faster.

Rate scale makes it faster in the preview window of the animation but doesn’t play any faster in game. I’m confused.

Also, I exported these at 30fps.

Got it, finally.
The problem was not the animation files themselves but was solved in the Anim Graphs transition between my ‘hold’ and ‘fire’ states. By default all the ‘transition’ nodes have a ‘Blendsetting/transition crossfade duration’ set to 0.2 which was basically cancelling out very my short 3 frame anim and making it run across this 0.2 time frame. At least I think that’s what it’s doing. So setting this to 0.0 and my anims are now being seen and played correctly.

That took me way to long to find :rolleyes:

lol well like I said ease in and ease out. :wink:

haha, yeah kind of.