Download

Frame rate drops after using editor for a while

Hey guys!

I tried to ask this question on Answerhub but without success. My frame rate drops whenever I use Material Editor,Static mesh viewer or just toolbar menu. This happens even with a blank map. For example:

  1. Turn on realtime rendering in viewport
    
  2. Click on "File" menu in the main toolbar
    
  3. Move the cursor on the "Edit" menu (or to any other menu in toolbar) then back on "File"
    
  4. Right click on the perspective viewport and rotate the camera view
    
  5. Check fps
    

I have to repeat step 3 and 4 a few times to make this happen. Right after I close menu clicking on viewport my framerate drops from 30 to 15. Turns out that UE4 process also drops CPU usage from 30% to 10-15%.

I run UE4 on laptop and use optimus (high performance adapter using by default). It doesn’t look like an overheating as my graphics card temperature is 50-55C and CPU is 60-70C. My system specs:

  • Windows 7 64bit
    
  • Intel Core i5-520M
    
  • 8 GB DDR3
    
  • 1GB GTX 560ti
    

P.S. I didn’t find any power management settings related to CPU or GPU, just a battery manager and few settings in BIOS that do not help.

Thanks.

You could try that:

open the task manager -> go to processes -> right click onto the UE4 -> set priority -> and the choose e.g high (but watch your cpu temperature)

Do you probably also have a 2nd gpu in your laptop? (because, most laptops have a “normal” gpu and another one)

fighter5347
I did try to do that but it didn’t help at all. Yes, there is Intel HD integrated graphics in my laptop and gtx560ti. I use nvidia driver to choose one of them but right now my laptop use gt560 by default. This only happens in UE4.