Frame rate dropped after NVIDIA driver update and Oculus Public Test Channel being on

Everything was working fine until the last NVIDIA driver update 3 days ago. Oculus home told me I had to update the NVIDIA driver, so I did. At the same time I also turned on the Oculus Public Test Channel.

I used to get 120 fps in the viewport, and now it has suddenly dropped to 20-60 fps.
The VR preview also used to be fine, but now it is so jerky that it will make you sick. I tried other projects that used to work fine, and now they are very slow.

I tried restarting and reinstalling the last NVIDIA update, but it didn’t change anything.

I had turned on the Oculus Public Test Channel at the same time I updated the NVIDIA driver. But when that was turned on it gave me a double set of hands in ue4 - I had the robotic looking ue4 hands and also the transparent blue hands from oculus. Sometimes the blue hands would turn into the black controller hand instead. I’d love to use those blue transparent hands in ue4, but not like this! (BTW: Does anybody know how to use those hands?)

I also had the same terribly jerky frame rate in Oculus home with the test channel turned on. But when I restarted all my programs, the jerkiness went away in Oculus home, but not in ue4.

So I turned off Public Test Channel in Oculus Home, and everything went back to normal, except for ue4. I no longer had a double set of hands. But the frame rate is still terrible. So I can’t say for sure if it was the NVIDIA driver or the Public Test Channel being turned on. But the Test Channel is now turned off again and the problem remains in ue4.

Any help would be greatly appreciated! I have to demo my UE4 VR experience at a large public event in a couple weeks, and right now the frame rate is abismal!

Here are my computer specs:
Intel i7 @4Ghz, 16 MB RAM, GTX-980, Win10. Oculus Home version NVIDIA driver version 388.59.
Let me know if any other info is needed

Had similar issues with the NVidia 388.x family of drivers, including some recurring crashes and even Blue Screens. Since then I have rolled-back to 387.92 and it seems much more stable. You may want to give it a try. When you perform the roll-back installation, make sure you do a clean install.

I also wonder if installing the Beta didn’t leave behind any services or add-ons which are still running even if now it is turned off. Difficult to say because probably you didn’t create a restore point.

Hey, thanks for the answer. That set me on the right track. I used Display Driver Uninstaller and got rid of the NVIDIA driver. Then an odd thing happened. When windows restarted there was no sign of the driver left, which is what I expected. I right clicked on the desktop and the NVIDIA control panel link was gone. Oculus wouldn’t turn on and Oculus home said I needed to update my drivers. Ok, that was what I expected to see. But then after a couple minutes the display flashed a few times and suddenly all the shortcuts to NVIDIA stuff started to show up on the desktop again. I right clicked on the desktop and the NVIDIA Control Panel link had reappeared as well!

I opened UE4 and started up my project. It all worked fine, with a solid 120 fps. I checked the NVIDIA control panel and I saw that I now had driver version 382.64.

So I don’t know what happened. I would assume that Win10 decided to restore some system restore point which had this driver with it. It apparently came from somewhere on my computer, because there wasn’t enough time for it to have downloaded the driver from the internet.

Anyway, it’s working again and I’m happy! :slight_smile: