Frame rate drop in 4.9


In creating a project in 4.9 I noticed a huge drop in frame rate when running it in standalone mode which I had not encountered in previous versions. So I tried another project (UE tutorial Endless Runner) from an earlier build with the same result. I then re-built Endless Runner from scratch in 4.9 with just the Blue guy and 10 floor tiles to get him running and again got the same poor performance. However when I re-built it in 4.8.3 -2634408 it ran perfectly.

The results are compared below:-

Frame Rates in 4.9 (4.8)

Normal viewport 60 (60)

New Editor (preview) window 54 (58)

New Editor (preview) window (full screen) 41 (43)

Standalone game 12 (62)

Standalone game (full screen) 4 (62)

I have not altered the default frame rate settings in the Project Setting and have left the engine scalability settings at auto. Switching realtime on/off in the viewport options made no difference.
I am running a VAIO laptop with Windows 8.1, i7-3632QM dual quad cores @ 2.2GHz with turbo boost to 3.2GHz, 8GB RAM and AMD Radeon HD 7500/7600. Overall system memory and CPU usage is only 20% - 40% whilst running with 4.9.

Am I missing something or is this a bug in 4.9?

Yes, same for me. I’ll would like to profile this, but there are many other problems currently so the values wouldn’t make much sense, sorry.

Did you create your own project to test out the frame rate, or are you using a sample from our Learn tab? Please provide additional information so that we can assist you further.


Thanks , looking forward to hearing back from you.

Just so you know, I had no trouble with Swing Ninja when I tested the frame rate within the standalone game on both 4.8 and 4.9.

Fair enough. Will make some additional test if I got the time.


Swing Ninja runs fine for me too but the problem with my 4.9 ‘creation’ persists. Here are links to both 4.8 and 4.9 versions. Would appreciate any light you can shine on this.

[2]: https://www…com/sh/icqy5x7xdfspt5h/AAALSwI6oe3QwqBRGYDRbrAva?dl=0

Hey Mojay,

Thank you for providing me with your projects. Both 4.8 and 4.9 versions of the Endless Runner you provided are at 62 FPS. Are you using any other programs while you’re testing these out?

I only have the two versions running and IE. System CPU usage is 25% and memory 45%. Should I try re-installing 4.9?

If it’s not too much of a problem, feel free to try reinstalling and restarting. Please post an update once you’ve finished that.


Tried re-installing 4.9 but no difference. Any suggestions? Ta

Hey Mojay,

You are using Binary, correct? Have you tried the released version of 4.9 from this morning yet? If so, did you have the same results?


Yes, correct. Just tried 4.9.0 - 2672455 with the same results.

I tested this out again on a desktop PC and a Macbook Air. As suspected, the Desktop ran at 120 FPS or 62 FPS for standalone. On the Macbook Air, the game ran at 20 FPS. There is a large difference in computer specs between the desktop and the Macbook Air.

Do you have another computer you’re able to run Endless Runner on? Also, have you been able to get this to happen in any other project?

I have to agree with you that it’s my low end specs causing frame rate problems. I have checked several projects and get varying (inc sub 60)FPS in both 4.8 and 4.9 depending on the complexity.
I won’t take up any more of your time but thanks for sticking with it.
Definitely time for an upgrade.

You’re very welcome, please let us know if you have any further questions. :slight_smile: