Frame drops when rendering image sequence as cinematic

Hey, I have been using unreal engine to make motion graphics and music videos for a couple of years now and I have constantly run into this issue which I would love to find an answer for.

Here’s what I do to create the problem:

  1. I build a scene for cinematic
  2. Set up sequencer for rendering cinematic
  3. Import image sequences to be used as animated textures
  4. Connect up media players etc
  5. Render out cinematic in 4k via sequencer

Problem: the animated textures in the render are very choppy. It might play smoothly for a second or 2, then freeze, then play at 2 frames a second… it’s all over the place.

It seems the common answers to this problem are - use image sequence, set a fixed frame rate, make sure frame rates of sequencer and image sequence match. however none of those seem to fix the problem. Usually I can improve the situation by compressing the image sequences I’m using in my scene down to small jpg files - although rarely does this remove the frame drops and stuttering entirely.

I notice that this problem doesn’t occur in a default scene, it only seems to happen in scenes which don’t run in real-time in the viewport. Though surely if I was doing this property it shouldn’t matter as I’m rendering cinematics not real-time games.

My best guess is it has something to do with unreal engine dropping frames in the animated textures because it is running out of memory? Though I am truly Not sure at all. I would have thought sequencer could handle this, and keep things in sync.

Does anyone have any ideas on how I might be able to get these animated textures to render frame for frame in my cinematic scenes I have been building?

Thank you so much :slight_smile:

if anyone else had that problem - ive found the solution.

you need to trigger the media from the sequencer, by adding a media track, and connecting your image sequence there rather than in level blueprint.

also, not sure to what extent this helps, but i’ve been told that musing the movie render queue rather than exporting directly from sequencer also can help with problems of this nature.


I was banging my head against the wall with the exact same issue and steps. This saved my life thank you

You are a lifesaver!! Thank you!

I was having this issue recently too and the above solution with playing the media in the sequencer rather than level blueprint didn’t solve it.

What DID solve it was in the project settings enabling “Hardware accelerated video decoding” and it rendered without any hitches through Movie Render Queue. I’m on UE 5.1.1.