Download

Frak'n VS 2015

what is the f’n deal with this dam IDE. Unreal doesn’t even acknowledge that its installed.
i’ve uninstalled and reinstalled VS Community twice now and its on the base version, no update 3 and UE4 is still saying this.

1fcb71dad84e38eaa1a33f5f872c6952797f2de4.png

As I recall, that message is because UE is looking for the VS140COMNTOOLS environment variable and it either can’t find it or the path it points to doesn’t work.

Check your system variables (Open Windows Explorer, Right Click on “My Computer”, Properties, Advanced Tab, Environment Variables) and make sure that entry exists:

c1fe3d77c56cd6bf8f390b7ecb48173698297f2c.png

If it doesn’t, you could try a few things:

  1. Repair your install and make sure the various C++ Tools/Compiler options are selected.
  2. Open Visual Studio 2015 once and let it do all its first time setup.
  3. Manually create the entry yourself (this should be a last resort).

SystemPropertiesAdvanced_2016-07-07_17-26-22.png

I just spent the past 3+ hours reinstalling VS 2015. and i’m still getting that dam error and my screen shows the same as yours

From the documentation

I installed everything, 40GB install. it still doesn’t work

You tried going the other way around and reinstalling the engine instead?

If it’s any consolation (it isn’t) - VS2015 sucks. compared to '13

did that yesterday. didn’t do anything. still wont find VS or VS wont find UE. who knows what the problem is. it worked fine a week ago. and now i’m behind in my work because I can’t use VS.

You can’t open VS at all now? Or its just UE not finding it? You might want to make a post on AnswerHub, you’re more likely to get dev help there than on the forums.