FPS get close to 1 when pressing F11

After getting new Computer (i7 5820K, 32Gt DDR2400, Asus X99-A (using the integraded soundcard) + GTX780, SSD, Win10 64bit from old computer) I have difficulties to play in editor using the bigger window view via F11. Sometime it work normally and FPS stays around 50, but often getting now instantly very heavy ~3FPS stutter that dont stop even when exiting the F11, stopping and returning to editor (stop the session). Stutter may even continue in editor until I drag camera some bit. Sometimes the stutter issue even begin to remain in small window view and I need to restart whole editor to get rid of it. While working in the editor, I have no issues. Its very smooth.

Very confused what is causing this (it always appear instantly only after pressing F11 while playing in editor). My old comp (i7 2600K, 24Gt ram…) didnt have similar issue and havent done any real changes in the project after getting the new comp few days ago. Havent got issues outside the editor (e.g. fallout 4 works normally) yet.

Edit: During the stutter CPU usage seems to get down too from ~25% to ~8FPS. Maybe some strange power saving issue. Tried already changing setting in Windows without help.

When the stutter appear in editor, you can get rid of it by minimizeing editor to desktop and coming back. But it dont work everytime. Is there some setting in Win10 to ensure max cpu usage for the editor. Cant find it myself so far. I disabled power saving option but didnt get any have effect.

Hey SaOk,

Thank you for taking the time to write this report. I am currently investigating what could be a Win 10 memory leak, which is causing an increase in GPU ms time and a reduction in overall FPS.

Would you mind testing this for me as well, so I can confirm it is happening in the wild?

Simply create a new blank project using the First Person Shooter template. Once you load into the default start up map, bring up the console command (~) and type “Stat UnitGraph”. Now press PIE (Play in Editor) and note the GPU and Frame time. Now toggle fullscreen mode on and off (F11), and observe the graph over about a minute to see if the numbers gradually increase.

I am going to enter a bug for this issue anyway, which is probably directly related to the issue you are reporting. Let me know if you have further questions or comments.

Thank you,

Andrew Hurley

Thank you :slight_smile: didnt yet get it íncrease in FPS template, but performance definitely leaks while editing my project. Will let you know if finding more details.

Yeah, and the interesting thing is I noticed it doesn’t just affect (PIE), but also while in the editor with realtime enabled. The GPU, Frame, Draw, and Game time threads are all slowly and gradually increasing. I have looped in another team member with a Windows 10 machine to verify this is occurring on their end as well.

I attempted to test this on my Windows 7 machine and did not get any sort of change in FPS or memory leakage.

Cheers,

Andrew Hurley

Hey SaOK,

Hope you had a good thanksgiving break, and I appreciate your patience while we got this bug entered. For tracking purposes the bug entered is UE-23894. I added as much information as possible to help locate the cause of the issue for this bug, and if you have since discovered any new information, please let me know and I will add it to the report itself.

Thank you for writing up this post and let us know if you need further assistance.

Andrew Hurley

I noticed the heavy stutter might appear when looking at certain objects. Have build one house from pieces and sometimes cant turn camera at it without getting extreme heavy FPS stutter. Even visible tiny corner of the house (tessellation material - not much polygons in the mesh ~100) destroy FPS unless turning away to landscape. Then suddently after minute I could again turn the camera at the house without any FPS drop. FPS does between butter smooth (around 50fps) and heavy stutter (less than 10fps) in identical camera views. The issue might be related to tessellation if I would guess.

But cant wait to see how your upcoming build updates will affect it :wink:

Hi, it seems the dynamic shadows may be leaking the performance. When I have those on in editor FPS is first good but slowly gets worse and worse. Had dynamic shadows disabled for around hour while working only on editor and when I enabled those back FPS in viewport and whole editor worked ultra slow (like 1 frame per 3 seconds). Normally getting 8-10ms hit from shadows, but suddently it gets many times more worse. Or the basepass gets bugged.