Download

Fps Drop in Unreal Engine 4.5

Hi, I’ve been working on a Grid based movement prototype (in Blueprint) for the Top Down template on Unreal v4.4.3. I was able to run it around 36 fps on an average. After updating to v4.5, I tried using the same project on the new version. I have tried simple copy as well as conversion on opening the project, but in both cases there is a considerable performance drop while playing the game. The Fps has gone down to a non-playable 5 fps. I’m not using any heavy materials/lighting in the level. But I have a lot of instanced static meshes (around 1600 basic cube type meshes) since I’m adding grid meshes dynamically on level start. I feel that this might be the reason for the performance hit. If not, there might be some changes in the default setting for lighting/shadows. I haven’t checked on that yet. I wanted to know if anyone else has been facing similar issues with performance. I’ve already checked the other posts here in the forum as well as the answer hub, but found no solution to this, except that someone else also seems to have a performance hit after mesh instancing for foliage.

Have you made sure that all the graphics scalability settings are the same as they were before?

For something like a lot of cube meshes you need to look into batching, since they are so low-poly having them as a single mesh won’t be that big of a hit on poly count and that would reduce the draw calls. I’m not sure how this is setup, might be something you have to do in blueprints.

@Xenome and @crumbaker Thanks, I’ll try it out. My motherboard got fried, so I’ll check it out once I get things running again. Meanwhile someone has also reproduced this issue and submitted a report in the UE4 AnswerHub.
https://answers.unrealengine.com/questions/109669/45-preview-very-low-fps-issue.html

@darthviper107 Currently I’m getting the grid locations from an array and adding the grid meshes at level start. But I plan to limit the grid to just near the selected character in the future. In that case, the spawning of meshes would need to match the level layout. I’m not sure how to use batching in that case, but I’ll look into it. Thanks.