FPS blueprint template causes AMD drivers to crash when firing many projectiles, occasionally crashes entire system

Steps to repeatedly recreate:

  1. Open UE4, create a new project using the blueprint FPS template
  2. Enter play mode in the editor
  3. Fire many projectiles into the air/into the world. Usually takes 5 to 10 seconds of this to cause the crash

Results of the bug:

  • AMD drivers will crash. My screen simply turns black for a few seconds while they attempt to recover. A basic driver crash warning is entered into windows Event Viewer stating the driver crashed and tried to recover
  • Following the drivers, the engine will crash
  • Usually the drivers recover after the engine crashes. Occasionally they do not and the system either crashes or needs to be reset.
  • If the drivers recover, attempting to un-minimize Epic Games Launcher causes it to crash.

What I have tried:

  1. Ensured my graphics drivers were up to date for my card (R9 380x 4GB, used AMD’s automatic tool). They were, no effect.
  2. Updated my graphics drivers to AMDs beta “Crimson 16.1 Hotfix”. No noticeable effect.
  3. Installed AMDs "Software Beta for ". No noticeable effect.
  4. Made this post.

I appreciate any help or guidance. I’m ready to provide any information that is necessary to resolve the issue.

You know this can be also driver bug

Of course! That’s why I tried updating my drivers, unfortunately to no effect. So it very well may still be solely a driver bug that hasn’t been addressed. I’m hoping that if someone else has had a similar issue then some parallels might be able to be drawn.

I will note some extra info here: This only happens for me with the fps template. I’m thinking it might have something to do with the projectile blueprint and its underlying components - perhaps the projectile component. We don’t use those sort of projectiles anywhere else (using ray traces instead) and so I can fire custom weapons all day with no issue.

I’ll try to set up a custom projectile and see if I can narrow down which component might be the root that triggers the crash (or triggers the driver bug which causes the crash)


Thank you for the report.

Yes, this is something that was noticed internally as well and it’s logged as JIRA UE-24826. It seems to be specifically related to AMD cards with the Crimson update that are on Windows 10. Our developers are working with AMD to investigate the issue further. We will post here with additional questions if needed.



Thanks for the quick reply and info. Happy to hear it’s on the teams as well as AMD’s radar.

Is there a public utility available to track the status of bugs?

Not yet, however that is also something that we are looking into.

Thanks. Happy to hear that as well.

Hey ARC157,

We have tested this internally and it looks like updating to version 16.3.1 (Driver Packaging Version 16.15.2111-160314a-300497E) fixes the issue for us. Could you give that a try and let us know if it’s fixed for you as well?