Found another bug in 4.4.0, this one is odd, guessing its a Slate bug

Hey Guys,

I had a bug just happen which is really odd. I created a Boolean variable on a Blueprint, gave it a tool-tip, assigned it to a Category and as I clicked on the ‘Private’ checkbox, it literally swapped that panel for one that has a transform and a bunch of other unrelated properties, check out the screenshot I posted below, you can see I even have the Boolean still highlighted… weird.

Just got another, this time I clicked the Category property of a variable and the whole Details panel disappeared… here is a screenshot

This is happing very frequently now. It’s almost every time I try to click a Checkbox that it switches or disappears on me. Thanks

Hi MC Stryker,

You’re right, this is a very odd issue. We tried to reproduce this on 2 different PC’s and haven’t been able to get your results yet. Try verifying the 4.4 install from the Launcher and if that doesn’t work I would suggest re-installing the editor.

Hey TJ, yea tell me about it. If you want, I can maybe take a video for you guys and I did find a couple STRs for this as well. I have to step out shortly for a little but let me know if you want a detailed video and I’d be happy to help you out.

Also as a note, this build is from the compiled source 4.4.0 release running in Development Editor I believe. Whenever I don’t program in Visual Studio for UE, I just double-click the project file so I’m guessing that’s the Development Editor build. Also, I won’t say it’s not something weird with my PC. It has been acting funky lately and I’ve been putting off buying new parts till the last possible moment so it may be that my ram is going bad.

I just tried this in the 4.4.0 Source compiled in Development Editor and still can’t get your results. Are you using the editor from the debug mode in Visual Studio or just starting the editor from the .exe?

Hey TJ, I haven’t tested it launched through Visual Studio in regards to this issue. I’ve basically gone through and compiled it however, I experienced this particular issue when I ran from double-clicking the project file. So I am assuming that is a Development Editor build but I am not sure. I believe I have only compiled Development Editor and Debug Editor builds thus far.

Hi MC Stryker,

I was able to reproduce some of what you are seeing. Although I couldn’t get the blank details panel to reproduce, I believe all of these issues are related to the same bug. I have entered it as TTP# 344342 into our tracking software and the developers will be looking into it further.

As a possible workaround, try making sure you don’t have anything selected in the Components tab. It seems to be showing the components details panel.

Hey TJ, glad to hear you were able to reproduce it in-house. So check this out, I’m not actually by my machine with UE so I can test this tomorrow for you but I think I remember it being where I created a variable and clicked the Category ComboBox. I may have checked the Private attribute right before as it usually was when I was setting up a group of DynamicInstancedMaterial variables and I would create the variable, give it a name and tooltip, clicked Private and set it’s Category.

I’ll test this in the morning and I think you guys may be up a little earlier since I’m here in LA so try that out and see if it happens to work. If not, I’ll try to replicate what I was doing and I’m very positive I’ll be able to give you exact steps to reproduce this since I saw this a bunch and in all cases happened when I clicked the Category drop-down. Just not sure what the order of steps are.

I’ll check in with you tomorrow and likely be on the Twitch stream as I’m usually on that. Take it easy TJ and catch up with you soon.

Hmm, the only time I can get the issue to repro is when I have something in the Components tab and have it selected. Once I have that, all sorts of strange things happen with adding or editing Variables.

Please let me know if you find definite repro steps without having a component added.

Sure thing TJ! I’ll try this today and get back to you. Thanks

Okay, so I did some initial testing and I just made it happen. What I did was type a bunch of nonsense into the Tooltip textbox and after doing that then clicking Category, it initially didn’t work but I tried to type in random characters into the tooltip window over and over again then click Category without hitting the Enter key and it did eventually happen. It appears to be a little random at the moment but if I see a definitive pattern, I’ll fill you in. If that doesn’t work for you, I’ll capture a video and if I can make it happen, I’ll share it with you. Thanks again TJ!

I’m still unable to get a repro with this method but if you want to make a video, please do. When our developers look into it further, it could help them track down the issue.

You got it TJ, already recorded a video and just in the process of uploading it to OneDrive. I’ll let you know once it is up.

Hey TJ, I was able to definitively reproduce this and document it on video. You can find the link below, take care!6313&authkey=!ACNKG65qMRcwzm8&ithint=video%2Cmp4

Thanks for the info MC Styrker. After seeing the video I was easily able to reproduce it and have added this to the TTP.