Found a bug renaming variables or assets

Hey Guys,

I found a bug when you rename variables and assets. But this only happens with renaming only the case of the character while keeping spelling the same.

Steps to replicate:

  1. Create an Asset, Blueprint Component or Blueprint variable and name it Myvar
  2. Then rename to MyVar and it doesn’t matter that you retype it, it always will revert back to Myvar

Hope this helps and take care! :slight_smile:

Yeah this has been known for awhile, but I can’t remember if they said they would fix it or not. It was in answerhub with a dev answer a couple months ago.

As a workaround, just rename your variable something completely different and then back to what you wanted with the correct case and it works fine.

Yea, I’ve seen this one in the engine for a little. I tried doing what you said when it happened and even just tried that now and it doesn’t work, it keeps reverting back. Thanks for the reply.

BTW… your Map Generator is looking pretty sweet! :slight_smile:

Thanks! :slight_smile:

Well that normally works for me. I suppose you can always delete it and remake it as long as you haven’t placed it in a hundred spots already.