Found A Bug Renaming Assets/Variables

Hey Guys,

I found a bug when you rename variables and assets. But this only happens with renaming only the case of the character while keeping spelling the same.

Steps to replicate:

  1. Create an Asset, Blueprint Component or Blueprint variable and name it Myvar
  2. Then rename to MyVar and it doesn’t matter that you retype it, it always will revert back to Myvar

Hope this helps and take care!

Hey MC Stryker -

Thanks for the tip, I’ve been able to reproduce this and have submitted for it to be updated.

Cheers

Anytime, glad to help out! :slight_smile:

For reference, this is an unfortunate side effect due to the way FNames work, as explained here: https://answers.unrealengine.com/questions/37398/bug-renaming-blueprint-with-same-name-but-differen.html

We’re looking into potential solutions to this problem.

Great to hear Jamie. I’ll just watch out and try to be extra cautious naming my variables until a fix makes it out in a future release. Thanks for all the updates guys.

At least when you try renaming folder you get the warning that you can’t rename to same name(still ignores changes to lower\upper case). It is still not very good, but warning is much better then nothing.

But renaming assets are still not fixed in 4.10, can you provide any update with this bug? It is really annoying, and can ruin a lot if you are using perforce(for example).

The FName case-preservation bug was fixed quite some time ago.

The issue you may be hitting renaming an asset or folder which differs only by case, is that Windows doesn’t allow you to perform a rename that differs only by case :frowning: