Forward motion not working on vehicle blueprint

Hey,

A common issue with vehicles not moving is that wheels’ axes are not all facing the same direction. Take a look at this answer here and the way pivots are set up. Hopefully, re-rigging will fix your issue :slight_smile:

I have tried to setup a car mesh and assign it to a vehicle blueprint. I get left/right wheel turns but not movement forward. I have tried looking at the example vehicle project but I can see what has been done differently. I can only guess that it is something to do with the bone arrangement or some input block somewhere.

Has anyone else got stuck on this?

226766-motion.png

Or sometimes it’s because the wheels aren’t actually making contact with the ground. Also, physics/collision settings can be a factor as well. The wheels are using physics to drive the vehicle forward so they need to be making contact and there needs to be friction.

Hi, thanks for your anwser. I have checked out the link. There is something a bit odd going on because I thought I had both wheels turning together at the front of the car, now I only get each wheel turn outward but neither turns inward.

Yes the wheels are fulling through the surface of the ground and the car seems to be sitting on the collision box around the body bone not the wheel bones. Both have collision setup though. Why would the wheels ignor collision?

They must not be set up right.

Make sure your meshes have collision set up, not just in the component but in the mesh. Maybe the wheel mesh doesn’t have a collision volume set up.

If I remove all four wheels in the actor and set the physics to small convex hull for wheels and remove the main hull physics completely the rear right wheel is in the correct position and on the surface correctly. The three other wheels gavitate to the centre of the mass (parent bone). I think there could be some self collision or physics error.

If I place the actual mesh in the map not the wheeled vehicle version then the wheels sit on the ground just fine.

Actually I have noticed in the physics the bones are parented (in tree structure) but there do not appear to be any bone contraints but there are in the vehicle demo. I am using blender to create the armature. I cannot not see any way to generate the correct bone constraints.

Actually there are no constraints because I deleted the collision box around the main body of the car duw!

Finally I have this working. You are 100% right it was a bone issue and re-rigging did work. There seems to be a scaling issue. This might be in my settings or could be a bug in blender export. I will detail what I did to correct it in some more detail for others to see as I’m sure I’m not the only one finding this difficult.

I found that I thought I had scaled everything correctly between Blender and UE4 but found that the scale factor in the export in Blender was not doing anything (I had no units set in scene).

  1. I scaled up my objects (armature and mesh) by 100x on X,Y,Z and rotated by -90 on Z. Applied rotation and scale (CTRL+A → Rotation Scale).
  2. Corrected bones to match with X,Y,Z directions.
  3. Exported with 1:1 scale and imported in UE4 1:1.

See bones in images below.

226908-top-ortho.png

226909-user-ortho.png

Hey James,

Thank you for sharing the details of your approach. I’m glad you fixed it :slight_smile:

Hi,

For all user of Blender who want to send their cars into unreal engine, I found a good solution and I think that this the only solution for Us.

First, I have to say that I spent 3 days to make a car ride. The reason why the wheels tends to go throught the ground is totally unknow to me, I tried a lot, a lot of solution and finally I used the SKELETON of the UE4 vehicle and it works perfectly!!

You have to PARENT WITH EMPTY GROUP
Then, you select all the vertex and associate them to the Bones depending on where they are.
Finally, you export that into UE4 and that’s it, that will work fine. So do not use the Blender skeleton for WHEELED VEHICLE blueprint.

Hope that helps!!

Hello,

I need to bring some precision to my intervention earlier.
With blender i tried to set collision and rigid body before exporting the skeletal mesh and it was still bad.

I mean I tried every possible solution like putting scale to 1, putting origin to zero and create more bone but It simpy does not work.

One thing I saw is that the physical state is fine but when you put the whell vehicle on it, things became crazy!!

No really understood the relevance?