Forum Bugs

There are some annoying bugs that pop up with the forums. Both in Chrome and Firefox. Strangely, at times the issues disappear. Alas, here are the two common ones I run into often:

  1. I get a notification in the message center about a new post in a thread I’m subscribed to. I get this when clicking on that:

  2. In a thread, if I click on a photo album, such as this:
    I get this:

I’ve even tried disabling all extensions/addons, and so on. These issues still arise. And at random, simply going to the next page in a thread can result in an error message. I hate to be “that” guy, but I have to call out that the vBulletin version the community is using, or at least the way it is set up, is really awful. It can be hard to maintain and make major changes without danger, but it’s starting to get annoying (and it will need to happen sooner or later).

Are there any plans to upgrade, or perhaps move to a more reliable and stable forum platform?

Hi there,

Thank you for reporting these issues. The forums have recently switched platforms, and fixes for bugs are still being worked out on a daily basis.

For the first, I too have seen that unauthorized warning when trying to access certain pages (mainly ones in the “Assets” sub-forum). The content in that forum requires you to be signed into your account in order to view those items, so if you see that again please double check that. If you are still seeing that message while signed in, please provide a link to the page so Epic can investigate further.

The second I have not come across yet, but I will keep an eye out for photo albums and test them out. (if you have an example please post it too!)
EDIT: Ok I came across one and didn’t seem to have any issues using the latest chrome browser. To be clear, you are clicking on the thumbnail image, not the “1 Photo” part correct?


Hey ,

Good to hear the issues are being addressed! As far as the first- it happens even while logged in. Next time it comes up, I’ll try and remember to copy down links, and will update here. With the second, it in fact happens when I click on the thumbnails or the textual album link. I’ve tried both opening in a new tab, or just clicking as well (though I prefer to open in new tabs, personally). Again, I’ll be sure to swing back here and report specific posts when it pops up.

I’ve let our internal team know about the forum with the Sub button. I did test the gallery myself and it seems to have resolved itself. Can you try that again?