Download

Force setup.bat to use HTTPS ?

Hello,

I do have issue for downloading dependencies with the setup.bat file of UE4, this one alway ending with a error operation timeout webexception, after a little test I noticed that I was able to manualy download the dependency file with a web browser by using HTTPS while it was impossible in HTTP (loop issue).

So i have simply generated a new GitDependencies.exe in VS2017 by editing the DependencyManifest.cs to use https as base URL for the dependency instead of http.

Sadly it did not solved my issue, the exact same error remain and it look like that setup.bat still using http protocol.

It’s been a week that i try to resolve this issue (tried the zip download on GitHub, tried to disable fire-wall…) without result, the only one which produced some result was by adding a -threads=20 to the setup.bat, the download resume for a little while then end by a corrupted package error in the end.

The weird thing is that I never had such issue with previous build of UE4 before today, not the first time that i compile a custom build, and the PC, internet provider and anti-virus are the same as before as well, to say that this problem is a total mystery for me.

PS: English is not my native language, but I try my best to be understandable, thanks.

Hi , Did you find a solution to this . I have the same problem

Yes and no, the issue eventually got fixed by itself, the issue was that for an unknow reason I could not establish connection to the Amazon server to download the remaining file of the dependency, until that one day it worked…
And i’m still completely clueless about what was the source of the problem, only thing that I am sure about, is that it was a network issue.