Force mip-map levels on a per-mesh basis?

Google is failing me. How to force mip map level on a per-mesh basis?

Use case:

  • the player can magnify objects for precise interaction
  • the objects are magnified in a picture-in-picture window via a SceneCaptureComponent2D


  • the objects being magnified are blurry because mip map level look to be based on the player camera and not the zoomed-in scene capture component

See pics. Ideally would like to force mip map levels to max while an object is being magnified and then return the object to normal when not being magnified. :cool:

Did you find an answer for this? im having the same issue with objects that are rendered through a SceneCapture2D onto a render target

Sort of … the only solution we found was to disable texture streaming on the entire project.

Project Settings >> Engine >> Rendering >> Textures >> Texture Streaming: off

Even on levels with many meshes and materials it didn’t affect FPS much. And all text is readable.

1 Like

Hi in ue5 is a solution for that on per meshes basis.

Mesh/mesh component → Texture streaming → Force Mip Streaming (check)

Force the streaming system to disregard the normal logic always load all mip-levels for all textures on that mesh when is loaded.

Another usecase is set this for material etc.

1 Like