Download

Force front X Axis problem importing/exporting character

My game is almost ready and now I have to use my finished characters instead of the basic Mixamo one.
I was having a problem importing the character meshes from Blender, than I decided to export and import the basic character, without use Blender and found this:

1) If while exporting the character I check “Force Front X Axis”, and reimport the 3D model to Unreal, it works. The 3D model is perfect.

2) If while exporting the character I don’t check “Force Front X Axis”, and reimport the 3D model to Unreal, so I have the exact same problem I was having when importing from Blender.

3) If while exporting the character I check “Force Front X Axis” like I did on “1)”, and import it on Blender, when I export back to Unreal I have the problem I was having on “2)”.

Here is the right export options:

export.jpg

Here is the problem.

I guess when I import to Blender or/and when I export from Blender, I have to change the armature primary bone axis, or manual orientation. I think that’s the problem but I don’t know how to solve. Here is the character and the orientation. I’m not using the humanoid rig, we just added a root the mixamo character, and yes, I know, he is not facing me. New characters (enemies) was made the right way, but this is the first one, the main character skeleton (there will be a lot of heroes using this skeleton).

I think I solved part of the problem: When I export to Blender, I check “Force Front X Axis” on the export options. When I reimport into Unreal, I uncheck “Force Front X Axis” import options.

However I have another problem:

When I import the character from Unreal, the Hips disappear on Blender. There isn’t a hips bone.
If I import the original file from Mixamo, the Hips is there. I have two questions:

**1) Why the Hips bone disappear if I export from Unreal to FBX?

  1. Is possible to make the Hips don’t disappear while exporting from Unreal to FBX?**

Searching for someone having the same problem as me, I found this link, and my problem was fixed doing this (last post): [https://community.adobe.com/t5/fuse-beta/animations-are-completly-twisted-after-download/td-p/10332665?page=1&profile.language=pt

I exported my character made on Fuse to Mixamo and reimported one animation in order to test. It worked.

I think the problem is on my old animations and probably if I reimport them with or without the ](https://community.adobe.com/t5/fuse-beta/animations-are-completly-twisted-after-download/td-p/10332665?page=1&profile.language=pt)Force Front X Axis checked, it would work, I guess, but I’m not sure, and also some of them aren’t at the same folder anymore.

It will be “easier” for me to reimport the animations using the character made on Fuse instead of the stantard Mixamo characteres. A lot of work, but that’s how I will deal with it.

I still would like to know why that happened, considering I didn’t change the Skeleton, just changed the meshes.