Download

Force enable distance field on old GPUs?

So in 4.15 distance field was force disabled on old GPUs. Now my GPU is one of them, How can I override it?

I tried to enable it via the project settings but it doesn’t work.

giphy.gif&stc=1

Distance Field don’t work in DX10 Cards aswell Tessellation don’t work in DX10 cards, you need a better GPU to work with it. DX11

It’s DX11 card (HD5850) and I can use it in 4.14, They just force disable it on 4.15.

And downgrade is not an option :\

BTW thanks a lot for the reply QQ, Here have an up vote champion!

That is rare then mmm With a DX11 should work mmmm

Sorry then I have no idea :confused: Probably you can download the sources and searhc by the name of the option, in the project you have to enable in Project -> Render the Distance Fields but out of that no idea what more you can do :confused: You can edit the source somewhere to force if you follow the path from the function name and on

I think that old AMD GPUs like the HD5850 have some bug that caused distance field stuff to not work correctly, so to avoid visual issues Epic just decided to completely disable the DF things on those. The only thing you can do is buy a newer GPU.

Dammit, It was working great, I only had issues when It was close to the built-in landscape system :\

Sure that there isn’t any config file that can override it?

Yes, quite sure there’s no way to override it. You could search for the commit on github though that disabled it and remove that, you would have to manually compile the engine then.