For those of you who use Mid to Low range PCs What settings have you found work the best for development for you?

Im trying to get a idea of what everyone elses opinions are on what they find works best to get the most performance out of their editor. Any tips/Tricks you might have or know to stop random crashing or freezes are welcome. Currently my system is a Asus G15 (laptop), Ryzen 9 5900HS, Nvidia Geoforce 3070, 2 x 1TB SSD, 40GB RAM.

Hi WretchedBeaches,

Low specs should not cause crashing/freezing, you’d just have a lower FPS.

First thing to do is change the editor scalability settings. (‘Scalability’ button in the viewport, or in the top-right settings menu)

Open the console (tilde key) and type stat fps to see how your performance is.

Also, my laptop user protip: to reduce overall load on your system (Your fans will probably spin up / be loud with an uncapped framerate) is to use the console command t.maxfps 15 for a quieter/less power hungry experience.

Thanks, sadly the freezing stuttering is exactly what i have even on a fairly empty landscape. ive set my scalability to medium as well as my texture quality level to the same. Its quite frustrating honestly, i have no other programs open and made sure no background processes were sucking memory. Still have have random GPU/D3D crash as well if i turn on lumen and do any landscaping. Ive also cut the cast shadows options from the directional lighting, and turned off a few plugins i didnt need. ive tried loading pre-made tutorial projects from the marketplace such as ( Valley of the ancient or Northwood) and those are so laggy and slow that its impossible to even test/control the characters. And once shading has been compiled if i press Play for them after 3-4 minutes i have the texture streaming pool over budget error then my GPU crashes. i have a 8GB 3070 and running task manager its stays at a constant 4.9/8.0GB for Dedicated. Now i do have two monitors connected the one using my GPU is the one i run UE on and the other for outliner/content Drawer / etc. Small things are fine but any actual level design or landscape my PC suffers lol.
Also i downloaded the studio drivers for my GPU instead of the game-ready version ad it helped some but still performance is a major issue for me.

Ah, that D3D crash plagues many people. Some people have had luck changing settings in the Nvidia control panel app.

Valley of the Ancient/Norwood are ‘extreme’ when it comes to required processing power…

I know on some laptops the external monitor port will only be able to use the integrated graphics (graphics on the CPU) - As an experiment, just try using one monitor. (Or no monitors) to see what the performance is like / if you’re still crashing.

One monitor on Integrated CPU and even though im using less then half my available VRAM im still getting a GPU crash.
Only things open are the editor and the task manager. ill try running Profile GPU and see what those stats are. But any way i can trace why this is happening with even that much vram availble?

GPU ststa

For the ‘One Monitor’ test you’d definitely want to use the output that’s connected to your discrete GPU.

Searching for ‘D3D Device Removed’ will give you many many more things to try. (After switching your monitor, I’d start with changing settings in the Nvidia control panel app)

Okay ill do that the abpve photos were from the single monitor thats on the discrete GPU (AMD), The Laptops actual monitor. Ill try messing around with the control panel settings and see what i can find out. Any suggestions? or tips on ones that are most important to configure?

I can’t say these are ‘most important’ to configure, but I was thinking about the settings along the lines of Solution 2 and 3 listed here.