For the love of god remove compiling in editor sound effect result

This is a follow up for

Going into Edit - Editor Preferences - Level Editor - Miscellaneous

58471-2015-09-13+16_33_13-editor+preferences.png

Im trying to disable the horrific high pitch noise that occurs when you initiate a dynamic compilation from editor.

This in fact does not disable this sound from occurring. Its seriously horrible, it should be removed or at least be capable of being disabled.

any update to this

I feel you man. I think it’s a ‘bug’. You can always disable the sound of the editor application itself from the OS. I assume you’re using Windows, go to the ‘Sound Mixer’ in your system tray and turn down the volume of the Editor application.

Holy Eardrums!
This sound must sound COMPLETELY different in some headphones than others. I feel like a Pavlov experimentee, I now associate recompiling c++ failures with mere mildy disappointing build break, but successes with excruciating ear splitting pain.

FIX:
In the Unreal Editor’s content browser, under View Options (lower right), make sure you have “Show Engine Content” checked.
Navigate to /Engine Content/EditorSounds/Notifications.
Right Click “CompileSuccess”.
Select “Reimport With New File”
Select any wav file that doesn’t burst your eardrums.

If you don’t have a .wav file handy, on Windows try something like: “C:\Windows\Media\Windows Feed Discovered.wav”

I dunno which is harder to believe, replying with a fix to a thread that’s 5 years old, or having PTSD from successful compilations. My ears STILL hurt.

1 Like

I came here, because it is funny, that this issue has been bumped a while ago and I put a fix for it long time ago :smiley: https://github.com/EpicGames/UnrealEngine/pull/1627

Thank you man for this! I´m bumping this topic because you deserve to be thanked and honored.

Right click on “CompileSuccess” and you can mute it.

It was driving me crazy.

:). Thanks.

I didn’t notice the mute option, good catch!