Download

Footstep sounds - first person issue

Hello,

I am trying to make footstep sounds for the first person character model. I used THIS video to guide me. At the end of completing it all, I still have no sounds. I went into the blue print for my “Floor” and I noticed that my GetWorldLocation was not being triggered by anything, which also would cause the LineTraceByChannel and GetSurfaceType nodes to not activate. . Could this be why I am not getting sound? Below are pictures and a gif for reference.

Any help would be appreciated!

Did you make sure that the actual object you are stepping on does respond to the Visibility trace channel?

Took a quick look at the video, and I believe he does not explain you have to set the collision response properly.

Thank you. Do you have a good video or search suggestion I should do? I found this on the unreal website- Collision Response Reference | Unreal Engine Documentation , any other suggestions?

You can use this link you mentioned as reference.

Go inside your object properties and look for its Collision properties.
There you will expand the options to see each Trace’s and Object’s responses.
Make sure the Visibility Channel is marked as Block. If it isn’t, you can either create a new specific Object Type you wish inside the Editor Edit->ProjectSettings->Engine->Collision OR you want to use the “Custom” Preset, and set each manually. Make sure not to change other responses accidentally and create weird behaviours in your game.

Also, if you want to know more about collisions, it’s pretty straight-forward. Youtube tutorials can handle this, and this video can certainly clarify most of things. Also, I highly recommend his channel for every situation you’re stuck or struggling to solve.

Thank you so much! I will check out the rest of his videos tonight.

Thanks again!!

You are welcome, good luck on your journey =)