Download

Footstep sound fall off

Hello,

I have a very simple footstep system that works. In the animation I use notify-play sound step. I am using a sound-cue for the step sound (dont know if that matters). Everything great except the sound doesn’t seem to have any falloff. I hear it AIhe same level no matter where in the level they are. Any help would be great! Thanks

I tried changing to a wave it had the same effect… There is no “falloff” option in the animation-notify-play sound. I wonder if it is possible to modify the actual wave or cue inside UE4 to automatically “falloff” on that sound?

I also looked into calling an event instead instead of play sound inside the animation notify section, but I did not see one

I was confused. Play sound at location doesn’t offer any “attenuation” options either. What I had to do was “find/make/steal” an attenuation. Then click on the sound and there is a drop down. That sound will always have attenuation no matter where you play it from

In the sound cue details …

**Attenuation… **
Allow Spatialization (true),
Override Attenuation (true)

Attenuation Distance …
Attenuation Function: LogArithmic
Attenuation Shape: Sphere
Inner Radius: 0-100
Falloff Distance: 3600 - 4000 (36-40m)
Enable Volume Attenuation: True


The way I setup footstep sounds is via custom anim notifies. The anim notify event fires a line trace to the ground to determine the surface type so I can play back the correct footstep sound (grass, dirt, mud, wood, concrete etc).

Take the location and pipe it to spawn sound at location. Choose your sound cue.

pretty straight forward.

Thanks for this!

Your Welcome :slight_smile: