Following modules are missing?

Whenever I try to build my c++ code for the first time, it gives me an error stating that
"The following modules are missing or built with a different engine version: UE4Editor-Code-Win64-DebugGame.dll Would you like to rebuild them now?
If I try to rebuild it, it gives me an error saying “Code could not be compiled. Try rebuilding from source manually”

I’ve uninstalled and VS2013, re-installed VS2015, and updated UE4 from 4.11.1 to 4.12.5 and still getting this error!

I’ve looked up about this and every forum or answer hub seems to say something different. I deeply appreciate any suggestions for tips to fix this.

It simply means two things:

  • The Editor is unable to load your compiled project, for which assets in the Editor depend on.
  • You are not able to compile your project.

There is some problem with your code that is preventing compilation. Solving these problems and successfully compiling your code will fix the issue.

You should be able to right-click your .uproject file and Generate Visual Studio project files, this will give you a Visual Studio solution that you can open. Then attempt to compile your project, and resolve any compilation issues that come up.

I am still getting the the missing dll error. If I try compiling in the engine I get and error saying:
Info UnrealHeaderTool failed for target ‘CodeEditor’ (platform: Win64, module info: C:\Users****\Documents\Unreal Projects\Code\Intermediate\Build\Win64\CodeEditor\Development\CodeEditor.uhtmanifest).

I have also tried Deleting the “Immediate” folder and generating visual studio project files again. And I’m getting an error when trying to build it beside the missing .dll

Severity Code Description Project File Line Suppression State
Error code OtherCompilationError (5) Code C:\Users\Name\Documents\Unreal Projects\Code\Intermediate\ProjectFiles\Error 1
Error MSB3075 The command ““C:\Program Files (x86)\Epic Games\4.12\Engine\Build\BatchFiles\Build.bat” CodeEditor Win64 DebugGame “C:\Users\Name\Documents\Unreal Projects\Code\Code.uproject” -waitmutex” exited with code 5. Please verify that you have sufficient rights to run this command. Code C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.MakeFile.Targets 41

did you ever figure it out?

I had this problem and this solved it:

  1. right click your project and click “show in folder” to see your project files.
  2. right click the [example].uproject file and click “generate visual studio project files”. (this may give you an error stating that you need windows SDK 8.1 to do this, just install that and retry)
  3. once this had generated, i ran my project like normal and clicked rebuild and it worked.

hope this helps anyone out there.

I tried to use the Virtual Studio but my project had NO C++ files and therefore it would not work for me. BUT, I did find a solution!!

  1. Open the project file in NOTEPAD. Its a simple text document, very similar to DAZ files.

  2. Find the line for the DAZ plugin and change the value from TRUE to FALSE. SAVE the file! (SEE THE IMAGE)

  3. Open your project and get back to work!

NOTE: AS OF 3-26-21 the problem will persist so DO NOT RE-ENABLE the DAZ plugin or the missing modules error will reappear.