Download

Following a dated tutorial - but I don't think that's the problem

Ok, so I’m following along with this series about setting up multiplayer in UE, and I just completed this session, and I’ve finally run into an issue I’m just not quite sure what is happening.

At the end of this session, it shows that the host and clients connect using the same data. Acceptable and explained in the video.

I have 2 problems:

  1. both my host and client do not see the host’s name.
  2. Player avatars do not load at all. (the small white squares. the big white squares are supposed to be empty)

We setup the options menu in this lengthy video and even though he makes a flub and made some people confused in the YT comment section, everything seemed to work fine.

This guy goes really fast, so I wouldn’t be surprised if it’s just something I missed. Any suggestions in general where to look? Would this be in the latest build out of this video? Thanks in advance.

Ok, so I found my own resolution for the Host name. I had forgotten to hide pins when I was setting data to the struct, so that is resolved.

I did some troubleshooting with Print String and noticed that the data is coming through, appropriately (Player name, avatar image name, statuses are all coming through as intended) but the images aren’t changing. They are bound to the variables as instructed in the video and still no luck.

Ok, here’s another weird thing… The first two images refer to what the tutorial says to do. It says to use this blueprint and bind the “AvatarImage” object to the variable. When I do this, it goes white.

I just bound the AvatarImage object directly to the object from the PlayerInfo struct for the image and it worked right away. What is happening?

EDIT: I also used “Set Brush from Texture” on the object directly from the struct pin, and it works. Setting the variable, and using that variable to manually “Set Brush from Texture” at the end of this seems to be the only fix at the moment. Added another screenshot to show the bugfix. I also removed the binding on the avatar image object so this would work.

I’m noticing that all of my binds are not working for images.

Ok, so I needed to confirm this was a bug, and I have created a nice clean, non-networked project to test, and I was able to replicate. Anyone else with 4.26.1 care to try it out and confirm? Maybe someone can point out what I’m doing wrong otherwise?

In the first 2 images, you will see that the image object’s brush is bound to the variable for the Texture2D reference. The blueprint code sets it to the brick texture.

The 3rd image shows how I modified the blueprint action to do the original action, then apply a bugfix similar to how I had to do the bugfix in my net tutorial. The blueprint code sets it to the brick texture, it sets it white in game, and the print string confirms it should have pulled the proper texture for that, and 5 seconds later you see the manual apply of the brush texture to the image object.

The 4th image shows the bug happen with the binding, including the Print String debug line showing the name of the texture that should have been applied. The 5th image shows the bugfix simply applying the variable that was already bound to the object directly to the brush as a bugfix.

Can anyone else confirm this is a bug, or tell me what I’m doing wrong?

Another thing to add, if I use “Create Binding” I am presented with a slate brush output… that’s probably not a bug, but likely a feature that may have been changed or added between the versions of the tutorial and 4.26.1. This manually created binding works.