Follow engine compiling tutorial: Fail

I followed this tutorial to make sure everything is set up correctly for the first time:

Everything worked, though the create project screen is missing the descriptions:

That’s not really an issue though as using those templates works fine.

However, when I loaded a template and tried to click launch, this happened:

I’m not sure what I did wrong here.

I had a similar problem. Did you build the Engine as well as the Editor? For me, I was getting the deploy errors because I had only built the editor. I went back to Visual Studio, did a batch build of all the Projects for all the Configs that I needed for my platform.

After that, I’ve had no problems.

You can see the error Exception in AutomationTool where it can’t find the appropriate files.

You want one of the “editor” configurations, probably development editor. The configurations without editor in them are for cooked games, which is used for final deployment.

Development editor optimizes everything, Debug editor optimizes nothing, debuggame editor optimizes the editor but leaves any game code unoptimized, for easier debugging.

Sorry for the slow reply. You’re best bet is to build all the projects for your given configs. Since you are using the Development Editor, I believe you need to build Development, Development Editor, and Development Client configs (with all the projects selected).

The client is your actual game, it doesn’t mean you are running a client/server game. What is happening is that when you try to build, it is looking for all the projects for the Development Client and not finding them (hence the error).