Download

Foliage painter not erasing

Good Morning All,

I cannot get the foliage painter to erase after I have painted anything on. Has anyone else had this issue? I’ve done a search but come back with no results. I have even beefed up the erasing to full strength but still isn’t erasing!

I’m using 4.5.

Thanks
Regards
Shez

If using world composition, make sure you have the correct level selected and active same goes for standard terrain. Also try giving the editor a reboot, standard IT tech response there but sometimes it works…

You should see the purple dome, make sure you are on the foliage tool as well.

Thanks for that ShadowKindGames however we currently aren’t using World Composition…yet…and it will sometimes erase. I definitely know the standard IT responses because I use to be IT Support myself before I got a job teaching the UDK/UE4 for a college :o) But yeah I’m still having to remove the instances from the painter then add them and paint again. It seems, at times, as though the behavour of the erase brush is linked with the camera vector. I’m not saying it is but it seems to be the way it behaves depending on the angle you are looking at it.

Hello :
Select which foliage you no need then press Shift+Left Mouse to Erase (note you should Select particular foliage in Add Foliage Type

I have had this very problem and i dont understand it, i am using WC, one tedious thing that worked for me was checking the “Single Instance” box, then and only then i could remove them one by one!

Put the erase density in 0, and try again :smiley:

5 Likes

ffs, that was unintuitive. Thanks for that!

Wow that worked, thank you, <hat the heck with the reversed value ??

While that density thing works, there should be some easier tool-sets or hotkeys to quickly select and erase either all foliage types or per single foliage type. Typical example: Having 10 different foliage types in a forest and just want to quick-erase some path or area. Maybe I am stupid but never found a quick way to use that.

Alongside this, a smoothing terrain brush hotkey would be cool that works anywhere for quick tweaks…even in foliage mode? Or some quick landscape mode-changer with mouse wheel for quicker access. The little things that makes the whole terrain creation / foliage placement a little more convenient and much faster.

Fk me… why would they have value that doesn’t erase as default?