Download

Foliage and setting up the starting level. Landscape and confused

I download the pack for landscaling like the tutorial said to do. I fount a mesh for the grass from google. This happens when I when I import it.

Not too sure what you’re asking but if it’s an asset pack you want with grass and trees etc try searching Marketplace for “Open World Demo Collection”. It’s FREE. I hope this helps. The asset ppack is very good and is designed by Epic Games themselves! =)

I need to try and word ■■■■ like this better, I guess I don’t know how. any way I have that all ready installed and it doesn’t have a green grass mesh. I looked threw it. unless it does and it doesn’t show up when I search for it. That’s what I need is an assets or 3d model on green grass.

If it’s a free grass mesh you want, then search for “Open World Demo Collection” on MarketPlace. They have grass in there. It’s free too.

I guess you didn’t read the post from me above. As I said, I all ready have that installed. The issue is I’m trying to setup some thing on the starter level. The videos I been watching show me just how to do it. I think I have some thing wrong. The last item I posted above is what I’m looking at. I removed the floor and the walls from that level. Now in the video I watch I have to have a landscape added to the level. I tried to add one to that level and for some reason it just vanishes.

This is what I’m looking at after the walls and floor have been removed. If you look at the top right. The landscape is missing. I tried to put foliage on what you see using a brush. and that didn’t work, No brush. So I don’t know what’s wrong or what happen to the landscape.

Ice

Why are you not using the landscape? - is it a personal choiche or do you just not know what you are doing? (It could go either way, if you really know what you are doing you probably wouldn’t use the landscape since it comes with really bad performance on mid range machines).

Regardless, the process is much the same.

Create a material, put the texture in the material,
press u and click for the uv / coordinate
Drag the pin out and multiply.
press S and click for a scalar parameter, name it tiling.
connect to the multiply.
Put the output of the multiply into the UVs, plug the texture (3 color) into the Albedo (base color).

Then create a material instance (right click material, choose correct option).

And apply the instance to the mesh, or landscape.

open up the instance, check the tiling parameter, play with its value.

Last but not least. Create a new empty level.
pop in a directional light, and a skylight.
pop in the BP_skysphere
save the level.
Click the sky, set up the direction light in the properties panel. It will auto update to the correct time based on the light rotation.

Proceed with landscape creation or adding of a mesh/with material.

Once that works you can and should add a post proces, unbind it, and set it up as you want/need for your project.

As a general note, forget completely about importing stuff.
Import the base things yourself and create the parts (materials, etc.) in engine.
relying on a 3d app to set up your materials is bad practice and 99% of the times completely useless, since more often then not projects will use some simple master materials and customized instances.

You must be missing lines as you read or your not getting what I’m trying to say. I can’t add a landscape. Every time I add one in. It Vanishes. And I don’t know why it does that. That’s why I added the screen shot above so you could see what is going on. I can try and add another landscape. what if it just vanishes from the world outlinner.

Look at this screen shot.

Do you see how this guy has a green landscape. This is what I need to do. and I haven’t been able to place a landscape in the starting level. Every time I place one and try to do what the video tutorials tell me to do it vanishes.

I don’t know what I did. it seems to have saved it this time and I don’t know what I did wrong last time. any way I followed you last post so what I have now

As you can see, The landscape is there. I made Material for it and added to the landscape. so why is it all black and not green like the grass material is.And are the 2 square blocks needed for anything

I wanted to let you know that I figure it out, The issue was with the Material. I just didn’t have it setup right. Thx for the help.

It makes perfect sense if you followed what I said that the landscape is black.

You need to go into paint mode, assign a layer type, right click the layer and fill it.

apologies for missing that in the walkthrough.
glad you sorted it.

And for what is worth, I think the level you were working on was either damaged or having issues, which is why I suggested starting from scratch on it.