Fog Question Exponential Height

I looking to add fog, looked at the tutorial and it says

  • Open Unreal Engine and go to the Place Actors section.*
  • Select the visual effects tab.*
  • Look for the Exponential Height Fog actor and drag it into the level you are working on.*
  • With the Exponential Height Fog actor selected, scroll down in the details menu until you find the Volumetric Fog option.*
  • Set the Volumetric Fog checkbox to true to enable volumetric fog.*

Problem is i don’t have Exponential Height Fog in my list? Actor> Place Actor > I have Lights, Primitives and Custom Actor but nothing saying fog?

Ok worked it out, click on the cube at top > Visual Effects > Exponential Height.

Actually not Solved :frowning:
Add the Exponential Height to the level, can see icon, click it to change setting but nothing happens? Watched a few clips and read the tutorial, change fog density does nothing

Any ideas whats going on? Yes i ticked Velumetric Fog

Still cant get it working. No fog is showing

volumatic fog ticked
visible ticked
fog density up higher
set graphic to Epic
anyone know why it’s not showing up on screen? 5.3.2

Hey there @2DNED! Sounds like you’ve done everything to enable the fog. So let’s just do a quick test to make sure it’s not just hidden due to editor. Create a light of your choice, have a solid angle, turn up their volumetric scattering to 4 and maybe increase their intensity a bit. Then hit G to see game view. If this works, it’s likely your viewport has fog disabled.


Thank you for reply, Fog is enabled (ticked) i tried turning it off as well as Atf F to see if it was working or any difference

ok i just installed a new project Basic setup for TPS
Did same, add fog, adjust setting, make sure fog it on in viewpoint and nothing…

Im using 5.3.2 is there a plugin i have missed or something, seems strange when such a simple process.

Solved, turns out it already must have a fog in there, delete the one i added, find the default one and change that and all is good.

You can’t have 2 fogs on the level or conflict, that seems to be my issue i had 2 in scene.

1 Like