"Focus Selected" Keybind Hardcoded in Persona

Steps Taken to Reproduce Bug

  1. In Edit → Editor Preferences → Level Editor → Viewports → Controls → Flight Camera Control Type, choose “Use WASD for Camera Controls”.
  2. Change keyboard shortcuts in editor preferences such that ESDF is used instead of WASD for camera movement. Change the conflicting “Focus Selected” keybind from F to CTRL+F.
  3. In the normal editor viewport, ESDF can now be used to control the camera, and CTRL+F will focus on a selected object. This is expected behavior.
  4. Open any asset which uses Persona. (e.g: a asset)
  5. Within the Persona viewport, ESD is used to move up, left, and down, respectively. However, pressing the F key will focus on the selected bone or figure. Holding the F key will eventually pan the camera right.

Expected Result

Persona should use the keyboard shortcuts specified in the editor preferences.

With the settings specified above, the F key should pan right, and CTRL+F should be used to focus on a selected bone.


This bug also occurs when the option to “Use WASD only when a mouse button is pressed” is selected. Even when Flight Camera Control Type is set to “Never Use WASD for Camera Controls”, the Focus Selected keybind preference is ignored and the hardcoded F key is used instead.

This bug was reproduced in version 4.10.1, but is likely to be present in previous versions.

Hi Eevi,

Thanks for reporting this. I’ve entered the bug in our system as UE-24755. Unfortunately we don’t have a workaround for you at this time.


No worries; main intent was to get the bug in the system.

I’m already using my own “workaround”, but it involves downloading the source code, finding Editor/Persona/Private/AnimationEditorViewportClient.h and changing line 1701…