Fmod in Unreal: Sounds work in editor but not in packaged build

I have Studio working like a dream within the UE4 editor, even in Standalone - but when I create a package, none of the FMod audio plays.

Could this be to do with missing data or something when it creates the package? or missing .dll files?

Pulling my hair out - no errors when the package runs, just no Fmod sounds playing.

Anyone able to offer any wisdom?

UE4.7.6 Fmod Studio 1.06.03

Trying this with both a 2d and 3d sound.



Same problem here, still haven’t figured out why.

I’m using a custom version of 4.8.3 (with some NVIDIA Tech added), and it works out of the box. However, I have a slightly different problem, which (at the first look) seems to be the same:

Only SOME sounds don’t play in the packaged build, others do. In the editor however, ALL FMOD Sounds are working.

Just a little tip: In the latest FMOD version (1.06.07), you have to add the FMOD folder with your sound bank to the Content directory of the packaged build (not in the .pak files). So if your game is named “Test” and the directory you choosed to package to is named “C:\Package” then you will have something like this:


This is where you have to put your FMOD folder in to. Hope this helps. However, this doesn’t solve my problem :slight_smile:

Does it work if you change build configuraton?


Thank you, fixed my problem. Really weird workflow IMO. (Packaging a game first and adding the sounds later, saaywuut?)

But it works. so thank you

I had the same problem, and indeed, copying the FMOD folder into the Contents folder solved the issue. Odd that the packager doesn’t copy the files for you.
But at least, it’s solved now. That’s a huge relief.

You can run the “FMOD Validate” option in the UE4 Help menu for a one-button fix.
I had a similar problem.