FMemoryWriter does not support data larger than 2GB

Hi guys im having problems packaging my project. I have cooked my content for windows and it keeps saying it failed. I then packaged my project for windows on development settings and that also failed. What am i doing wrong?

Are there steps to packaging because i tried cooking first then packaging. can someone tell me what is wrong with my packaging. I have uploaded pictures of the failed settings

there seems to be a problem with TPF. It says “failed while setting focus to the disabled TSF document manager” and also RunUAT.bat ERROR: automationTool was unable to run successful


Howdy StefanTheArchitect,

Thank you for reporting this issue. Would you be able to include your DXdiag and your project log files so that I may further investigate this issue?

Any additional information would be greatly appreciated.

Thanks and have a great day!

[link text][1]

21797-uat_log.txt (171 KB)

Hi thanks for the reply,

I have been able to package the default programs but not the one i just created.

I dont know if its because of the blueprints Ive created or lighting issue. Ive been able to package my project during its early stages but now it keeps failing.

Here are the files you were looking for

[link text][1] [link text][2]

21811-dxdiag.txt (32.6 KB)
[2]: 21813-cook.txt (129 KB)


Hi mate,
Looks like it’s having a problem cooking because the package is too big.

FMemoryWriter does not support data larger than 2GB. Archive name: H:/grad project/MyProject/Content/Maps/Building_And_Land_And_Road1.umap.

This is problematic for many reasons, you don’t need to cut anything out but I would suggest splitting it up into different levels.
The persistent level can contain any number of levels, all these levels will be loaded when you load the persistent level in the editor.
Perhaps this tutorial will help.

Thanks a lot for the help! It always bothered me why it wouldn’t cook.


just wondering…you talking about spliting it to resolve the problem…but why migrating everything to a new map helps??

Hi 1681166xp,

I can’t see where that is suggested, can you elaborate? If it’s mentioned in the tutorial you will need to ask the creator to explain.

I’m sorry my bad…after migrating into a new project all lightmaps resolution was set back to default, thats why it worked again…the problem was all the time the lighmaps - the data was just too big overall.

I have this same problem but it isnt helped by splitting up the level. I’m working towards an ArchViz live walkthrough for a client. The game plays fine in the editor window. I’m really just after that as a .exe. I’m encountering this error :link text

I have fully unwrapped every model with Light Uvs Maximum lights UVs are 2048. The geometry spans roughly 40K square feet. I’m dealing with roughly 300 lights, which is a bit excessive but its the clients request.

Any advice would be greatly appreciated.

Hey BigFudge1488,

Can you tell me exactly what you’ve done to split up your level? Have you tried streaming levels together so that it takes the load off of the umap file?

Looking forward to hearing back from you, thanks!

Hi all , I’m working on an Arch Viz Project ( 2BHK Apartment ) and I was getting the same 2GB limit error, So I split my entire level into 5 sub levels,and I have given Always load as the streaming method. but still I’m not able to cook/package the file.But If I delete the build data from the file it will work. Please help me out to solve the error ASAP.
Thank You


I’m dealing with the same problem. Could you solve it?

Hi, I also have the same problem…does anyone know how to solve it?

I am using the lighting scenarios feature and it seems that I can not split the lighting data… any Ideas? So a similar problem…


In case anyone else was getting this error and can’t resolve it, try deleting the map build data.
It worked for me after I had tried everything else.

Wish I knew why it worked, but there you go.

map build data was the culprit for me as well thanks for this so much!! for anyone new this data is in the same folder as the map file.

Hi, I am having similar problem.
My level has 23 meshes in it with Overridden Light Map Resolution of 2048, 2 EXR map for skydome, 2 Lighting Scenarios and no reflection captures.
Below are solutions that I’ve found online and tried but none of them are really good solutions to this issue.

1. Splitting the levels.
Doesnt work. My level only has 23 meshes in it. I split the level into 7 sublevels (approx. 3 meshes in each sublevel) and it still wont package the game.

2. Set Compress Lightmap to True.
It works, but lightmaps show visible lowres gradient banding. Not preferable for archvis works.

3. Reducing Overriden Light Map Resolution from 2048 to 1024.
It works.

4.Deleting Map Build Data
Build data contains the baked lightmaps. Deleting this will erase the baked lightmaps. So this is not a solution.

5. Reducing World Settings > Lighting Level Scale
This affects the look of final rendered results. This is not a solution too.

6. Pack for Shipping instead of Development
It doesnt work. Packing for Shipment still gets me the same error.

7. Too Many Reflection Captures.
I dont have sny reflection capture in my level, so I dont think this is the cause.

8. Set World Settings > Packed Light and Shadow Map Texture Size to 1024.
It doesnt work. It is 1024 by default when I have this problem.

These are what I found and have tried. If anyone or Epic has better solutions, kindly do share.