Fly around as editor when I press play

When I press play I don’t spawn as the player character anymore and just fly around as an editor. I’m not sure what happened.

(post deleted by author)

If anyone else has this issue, I watched a video on how to make the player from scratch to troubleshoot (https://youtu.be/Tf4rpJfOy54?si=ylg9RIol1o5_W0X4), it seems my game is spawning a default pawn instead of the player so you have to force the game to possess the player. In your map viewport, go to the “settings” on the very top right of the screen and choose “world settings”. From there there is a tab called “game mode”. Under “game mode override” choose the gamemode created for your character. Then drop down the selected game mode pin and under “default pawn class” choose your player blueprint (ex BP_ThirdPersonCharacter). Lastly, go to your player blueprint. In the viewport under “components” on the very top left, choose the very top one that says the name of the blueprint with (self) after, (ex BP_ThirdPersonCharacter (self)). With this selected, go to the details tab on the right. Search for “Pawn” in the details tab and a setting called “Auto posses player” should appear. Click it and choose “Player 0”. Your game is now forced to spawn the selected player character rather than auto-spawning a pawn which just kinda makes you fly around. Hope this helps.

Set up the Game Mode properly since it’s its job to spawn possessable pawns.

And you will need this for a lot of other things, too.

1 Like