Fluid simulation using collisions

I’m trying to understand how fluid simulation plugin works. I’d like to use actors which will be colliding with my 3D fluid.
In the reference (Niagara Fluids Reference in Unreal Engine | Unreal Engine Documentation) , it says “When Collide Against is enabled, select the simulation in the Level Editor to adjust the Override Parameters and select specific actors”.
I figured out we have to use Geometry Collection Actor. I created one an place it in the level. But as soon as I select it in the parameter GeometryCollectionActor, Unreal crashes.
Is it me doing something I should not or the engine has a bug?

If I understand your question, you want the fluid sim to collide with an actor. All you need to do is in the actor you want to be collding with the fluid sim, in the details panel type in tag, and under Actor>Advanced>Tags add a new tag and type in “collider”
If this isn’t working, go into the niagra editor and in the fluid emitter box (the second orange box, not the paticle box) go to Emitter Summary and in the side panel select Simulation>Collide Against and make sure the type of actor you want is ticked off. Static mesh should be ticked off by default.

1 Like

ok, thanks
Now is it possible to collide with an invisible mesh using mesh distance field? I could not make it.

Found out we can make the mesh invisible using a Material in Mask mode opacity 0 and it will remain visible in the distance field realm.

Does anybody here know how to fix the niagara plugin when the fluid leaks through to meshes wich are perectly combined?

The mesh distance field is perfect, but i dont know why the fluid works not perfectly fine.

Does the material affects the fluid with the opacity option?