Floating Landscape Grass

Hey,

I’ve noticed sometimes that ill open a map and my Landscape Grass is floating rather than being aligned to the ground.
Anyone have any idea why it might be happening? Even when i roll back changes I’ve made before it happens, it doesn’t revert back and i cant figure out why its happening.

I’ve tried

  • Re-sampling the landscape
  • Changing landscape layers on which grass is rendered
  • Importing a new landscape
  • Creating a new landscape using the landscape editor
  • Creating a new landscape grass types

I might have tried other options as well but just cant name them all. Seems like no matter what i do, I have to resort to creating a new level just to continue working, but its a massive pain in the ■■■■ to do so just for one small (but visually massive) issue.

Has anyone run into this before and managed to fix it?

Thanks,
Beni.

Edit: Forgot to attach the screenshot

same problem here

might be related to this thread:

in editor console, type: RemoveLandscapeXYOffsets

1 Like

Thanks paradoc, i managed to address this issue a while ago but forgot about this thread! Thanks for adding your answer, thats what fixed it for me.

version 4.20.3 , I have the same problem :confused:

Thank you SOOOOOOO much! I tried to fix this for hours and got so frustrated and thought that I would have to leave it and somehow cover it up. The command works perfectly, thank you!

Literally every system in UE is garbage and doesn’t work properly.

1 Like

Getting the same issue in UE5. The console command seems to do nothing at all.

Got it to work by typing : grass.flushcache

1 Like

So I tried grass.flushcache as well as the offset command and neither worked for me. Anyplace I pained the grass I got the floating layer. I realized the grass is sitting where my landscape was initially created as apposed to where it was lowered to.

Having the exact issue as Casriell3. Perhaps someone has a solution not yet mentioned?

Out of frustration with this exact issue, I put my terrain back to the original import height and the Landscape Grass Type started populating (total guess work as I had not seen this thread) I then put it back to my intended Z location and the grass went with it. Not sure if you have editable layers enabled along with world partitioning — I do and I am not sure if this has any relevance to the bug. However, It appears to be working fine at the moment.