Download

Flipbook Collision instead of CapsuleCollisionComponent

So after working on a game in JavaScript, I thought of porting it to UE4 just to see how good the Paper2D implementation is.
But after playing a bit, I got stuck at the very beginning. How the hell do I use the generated flipbook collision boxes on my flipbook character? I can’t find a way
to delete the CapsuleComponent.
I mean, wtf? That makes the whole flipbook 2d collision thing pointless if it doesn’t work on a character!?
So any ideas on how to get flipbook collision working instead of this useless CapsuleComponent?

~Frostbyte

I’m fairly new to Unreal Engine 4 and paper2d but you can implement the collision on your paper2d sprites and use the collision on your paper2d sprites, with just a few edits. I normally use my capsule for traces and AI logic.

To give you an example of how I achieve this, my capsule component is really small like a 10 by 10, on a huge creature (whose collision I use instead.) if you select your capsule-> go to collision -> set it to custom -> and set that to no physics collision, it will only be useful for traces. I currently customize my stuff as well because sometimes I want a little more with the options and my player/enemies.

Next step is, on my flipbook character/sprite component inside the blueprint-> I have set it to block all dynamic and enable generate overlap events.
(note: in the sprite editor I have set the collision to either box or shrink wrapped so I can have some pin point collision, and thickness normally set at or above 40)

set up like this, all my “physical” collision is now coming from flipbook character.
(note: flipbook must have collision enabled as well.)

final note: Capsule Component is going to quickly become your best friend. A lot of functionality is built around it. it doesn’t just work for collision but for traces and for logic building with other components that you will build for your game.

Ah okay thank you <3 Going to test it out later, I’ll edit the post then.

Sigh no matter what settings I use, it still won’t work. What did I miss?

Here are my settings and my BP logic to test it:

When I start the map, it outputs
Capsule Overlap Occured!
Overlap: Floor
and I fall through the floor.

Of course I set the collision in the flipbook to “use first frame collision”.

Quicknote: I forgot to set the “Simulation generates Hit Event” flag. However, regardless of the flag, I would see the collision in the viewport if they actually collided^^

So no Sprite Collision at all :confused:

Your Capsule component is what needs to be tweaked to get the results you’re looking for. everything else seems to be set up correctly. keep playing with the capsule component collision til you have something you’re looking for. I currently have it set to character mesh for my main character, while I have my sprite collision actually set to block all dynamic and to generate hit events.

I’m still as well learning the system and I discovered that hit collision on the sprite is enabled when you actively collide or overlap something, but when you’re acted upon, it does not do anything. which leads me to believe that there possibly needs to be another component added to handle incoming collision.