"Flickering Panels" while Rendering Point Clouds from LiDAR (.las)

Hi everyone

I’m a complete novice with Unreal Engine and 3D modelling in general. I’ve recently started trying to learn photogrammetry and am particularly interested with importing point clouds created in Agisoft Metashape (.las files) into Unreal Engine (or other software) with the goal of making animated videos. I’ve been teaching myself with some help from friends and random tutorials/online documentation.

So far, I’ve gotten to the point where I can import dense clouds, create a scene, and render to video; however, I’m running into a persistent problem where squares of the point cloud flicker in and out of view in the final render/export. (see my sample video). Sample Video

I’ve done some troubleshooting and experimented with things I’ve read could be the problem: global distance value; occlusion distance value in global settings; scale bounds and z-values; building lights - but I’ve gotten to the point where I’m out of ideas and out of my element.

I suppose another question I have at this point is: Is there a different piece of software that would allow me to import point cloud data and render video from it?

If anyone here knows what’s going wrong or can point me in the right direction, I’d appreciate it. Thanks

1 Like

looks like particle sorting order issue or something with particle culling you could try the new movie render queue stuff and render out different passes to try to pinpoint what the issue is

Did you figure out why this flickering occurred? I’m having the same issue with my lidar scans, and can’t figure out how to fix, or minimise this effect.

1 Like

+1 here. I’m experience the exact same pattern of glitching/flashing and have been seeking a solution all week with no luck. I’ve tried varying all options of the plugin settings and testing in the editor as well as packaged versions of the game for Linux + macOS.

1 Like

+1 Here! Can’t get rid of it…

Same trouble here

1 Like

same problem, Pointcloud seems to reload every frame

Hello ! has anyone found the solution ? Same issue here :frowning: The cinematic is perfect but when it’s time to render I have a lot of flickering…

Hi everyone!

I was having the same problem but I think I found a solution. I have been exporting some test and there is not more flickering and glitchy stuff. And also the point looks more consistent, their density and the size. Everything looks like what I was seeing on the original scene inside of UE

In the movie render queue I am adding these things on the exports settings:

In the export settings first selected console variables and add these settings.
r.ScreenPercentage 200
r.LidarBaseLODImportance 0.1
r.LidarPointBudget 1500000
r.LidarTargetFPS 59
r.LidarScreenCenterImportance 0

I got that information from here:

And I am also adding an Anti-aliasing:
Simple sample count 1
Temporal Sample Count 64
And check the Overide Antialiasing option

And the result, I just created my account so I cant upload more images of videos, sorry

Left: Before / Right: After

Let me know if this also works for you! :+1:


hmm… I tried the same settings, but the render doesn’t keep the points together.
Not sure if there is any other workaround.

Any chance to jump on a zoom or meetup session?

thanks man and keep rocking,

Hi Guys! Just try to add this line in the DefaultEngine ini file of your Config Folder:

In fact Unreal rendering is limiting the Point Budget Rendering to 1 Billion by Default. So depending of your GPU Power, you should set it to 3 or 5 Billion ^^

1 Like

Why would you target fps 59fps (it’s offline render, it should be set to 0)

also 1.5M point budget is quite low and won’t make decent render.

Has anyone found a fix that works for this already as I’m experiencing this myself in 5.3