Flickering materials on M1 Mac using UE5

Hello developers,

I recently got a M1 pro MacBook Pro and wanted to try to use UE5 on the go with it.
I tried to load a level, and I have this strange flickering issue with some materials (I’m using ALSv4 right now but I had the same issue with the StackOBot project).

I tried with UE5.0 and UE5.1 preview 2 and nothing changed. It appears that some materials are not affected by this issue, like the character material, or some white props in the background.

Any ideas on how to solve that ?

1 Like

TBH it looks like a GPU video memory problem at first glance.
Do other 3d programs / games work OK?
Have you tried switching to Vulkan as your RHI?

The same situation. 4.27 works pretty good, but 5.0.3 and even 5.1.0 Preview 2 works like on that screenshots

1 Like

Perhaps your pc isn’t handling lumen well. Have you tried turning it off and seeing if it clears up? (in Project settings =>Engine => Rendering => Global Illumination / Reflection)

I tried both of your ideas and none of them seems to work. Yes I have been able to play a few games without issues. The project is really lightweight and almost empty so I do not think it is a performance issue.

I tried using Metal 3.0 but it crashed when I launched the engine.

Saw this as well with 5.1p2. Built from source (as native, not Rosetta) and it came up, no flicker, but tells me I need to recompile Lightmass…which errs out with compile errors. Thus I don’t have a solution for you either, at least not until I can get Lightmass to compile.

1 Like

@Jos.Goldstone you have to find the lightmass module and compile it first (in vs right click & build but not sure how it will be on mac)

I tried to compile from source too but I faced some issue. I guess it’s worth to try again if it works for you.

I rebuilt from source and it worked like a charm. I followed the steps available on the Unreal Engine 5 GitHub for those wondering.

Thanks @Jos.Goldstone !

I had no luck I compiled from source new Mac M1 Max studio- on load of project that was working fair in silicon binary , black screen in editor nothing loaded, ideas ?