Flickering all over geometry. Mixamo issue? Skinning?

Hi everyone, been learning UE4 and loving it and getting all my assets Ive created for a project imported into Unreal just fine. Everything looks good too except for my rigged characters which are from Mixamo, which I need to use for the facial rig it comes with.

I am attaching a short video of whats happening. This is with a character I made with Fuse, only difference is I made a new shader and added my own texture on it. But Ive tested this with characters straight out of fuse, downloaded from the website with the autorig. And checked it out with and without textures. No difference.

Basically the closer you get the worse the flickering is and its all over the mesh on every character. Ive tried multiple characters with and without facial blendshapes too as I thought maybe it was a zFighting thing but I don’t see how it could be. I even brought it into Maya first, and made sure all the extra geo for blendshapes and everything was gone but this still happens. No extra geo and no overlapping polys. Even if there were it would only be at the edges of clothing but this is all over the entire mesh.

Is it a skinning issue possibly. I even tried the geo only, without any skinning or anything, just the mesh alone from my fuse character and exported it, and when I brought it into UE4 it actually looks ok. So im lost here as to what’s happening. Same mesh looks ok without being skinned to a rig but the rigged character flickers really bad.


Thanks for any help! Im sorta stuck and cant proceed until I resolve this issue, its killin my whole project…:frowning:


im not entirely sure but I think your problem is in the ballpark of LOD.

looks like its accidentally spawning a lot of actors, and the result is z-fighting.

That’s Z-Fighting, where polygons are trying to occupy the same space as other polygons, it tests the depth to see what to display and it alternates between the two surfaces. You’ll need to find out why there’s two meshes there.

Well see thats the thing, there isnt an overlapping mesh. Ive checked that several times. Ive even opened the fbx back up in Maya and deleted a single face to see if there was another layer of geo and it didnt have any. And if I take the EXACT same mest and just delete the rigging and import it as a mesh only, it looks fine. SO was wondering if its a skinning issue or something like that I dont know.

Could it have to do with blendshapes? Maybe an fbx export thing that makes duplicate meshes to make the blendshapes work? I dunno, grasping at straws here, but Ive checked the mesh several times and it’s not doubled up.

your blueprint might be spawning two though.

How would I check if it is? It only shows one skeletal mesh and I exported it back out from unreal to check and it in Maya and it doesnt have any overlapping mesh, and opening the same asset in Maya and inporting it into unreal shows close to same number of vertices (weird its slightly different but not different enough that its a whole other mesh, just a few verts.

Not sure if it matters either but it flickers in every lighting mode EXCEPT for “lighting only” which shows just the lit geo and no textures. However Ive replaced all the shaders with basic new shaders in unreal so dont think its a texture problem.

Thanks for everyone who’s tried to help so far though, this is frustrating, Im totally stuck and out of ideas.

Try swamping out the material with something basic and see if it goes away.

It’s possible for two textures to share the same z-plane causing the material to flicker.

Bit wordy but what I ran into a while back.

Hey FriankieV, thanks for that link and the vid you made. I got excited as I thought that might be the solution but unfortunately no. I attached another video here. I actually brought in the characters and made a breand new blank material and applied it to the whole character. I even added a 3Vector Constant to the Base Color to make it red and also afte rthat didnt work I added a constant to the Normal and set it to 1 like you did to see if maybe it was a priority thing like yours but it was the same result unfortunately, ****…

Here is the vid:

Where did the source of the model come from?

As a though when importing via FBX you do have the option of combining the model as a single object and some packages included LOD’s so your z-buffer fighting could be caused by two models sharing the same space as imported.

What 3d app do you use?

It’s Mixamo. Exports as an FBX. Ive checked it in maya and exported it there even as the FBX2013 method. Also straight from Mixamo itself. These are characters created with their character creator called FUSE which is more meant for Unity but should be able to work in Unreal too with a little tweaking, they used ot have the option for Unreal but took it away but that was just changes in bone hierarchy, not geo. And I’ve even exported the mesh back out of Unreal and opened it in Maya to check and there is no extra geometry. So unless Unreal is duplicating the geo when I import it somehow and then deleting it before I export, I cant think of any way there cold be extra geo appearing. The geo does have history on it for Blendshapes if that might be a source for the issues happening.

But Mixamo doesnt have any options for LOD and Ive imported and exported so many times looking for this stuff I cant imagine it would be there anyway. And I cant just combine the mesh into one piece as I need each part (head, shirt, pants) to have its own UV space for resolution of the type of textures Im going to use. And I need to use the Mixamo as my pipeline is set up for using it with the facial rigs it builds into it via blendshapes.

Ive also gone into the FBX and made sure there arent any extra hidden pieces of geo from merging blendshapes.

This is a short Im doing and was originally working in viewport 2.0 but running into too many limitations and bugs so wanted to rebuildit all in Unreal, but Im completely stuck right at the start with these **** characters. The skeleton and animations work great in scene, its just this flickering…

I mean I know it looks exactly like zfighting, I would assume it is but can’t for the life of me figure out how the geo is doubling, when, how, etc…

I was getting something similar to this in my project, I fixed it by going into the parent material and setting under Usage options “used with skeletal mesh” and “used with static lighting” make sure those are checked.

Alright! Ill give it a look-see tonight! thanks!


DANGIT!!! I solved the friggin problem, arrrrghhhh. Frustrating and relieving, but i wasted so much friggin time with this and doesnt really make sense to me but the solution is:

Mac OSX is the problem!

Yep, that’s it. I loaded up bootcamp tonight and installed the Unreal Engine on Windows 7 install (Its an old windows install I have for playing STEAM games). Opened it and started a new scenee, imported all my characters and BAM works with ZERO problems straight outta the box. Even loaded several versions that Id been experimenting with and having issues with this last couple weeks in the hours and hours i spent tinkering around to find a solution and whaddya know they all work just fine…well at least i learned alot about Unreal in the process but ****…

Its so weird though because its just in bootcamp so its the exact same graphics card, just different OS. But it’s solved! So if anyone else has this problem and finds this thread, try it in Windows FIRST!!

Also thanks for the tip “Cr1tlord”. Tried that before all this and no dice, but it was worth a try, thank you. And thank you FrankieV, darthviper, and everyone else on the thread who chimed in to help. Really helpful community here, hope I can do the same for others down the road. Cheers!