Flag for when a dino rider is at the surface?

I imagine that if this was possible someone would have done it by now, but it’s really annoying me so I figured I’d give it a shot in the Dev Kit. Essentially, what I want is to mod the Tuso (Tusoteuthis vampyrus) so that an oxygen regeneration buff is gained whenever the player is at or above the surface while riding. I imagine it would be somewhat simple to add a constant oxygen regeneration buff similar to the Liopleurodon’s Mystic Skin Oil to the Tuso, but if it were a constant regeneration buff people could abuse it by mounting whenever they run low, regardless of whether they’re near the surface or not. Obviously there’s some kind of surface flag which triggers normal oxygen regeneration, but as to whether or not one can edit it in the Dev Kit in a way that fits with my goal is where I’m lost. If anyone has encountered something like that, or knows of other potential remedies, I would love to hear it.

I would imagine this would probably work…


Its either that or just from the volumeleft trigger … i didnt get too deep into it, but, those are the 2 things that would control knowing if a player is or isnt under water.
I would assume, by naming convention lol, that the node would decide what happens when your above/below and the flag to initiate that node would be the “VolumeEnter” and “VolumeLeft” setups.

@P0k3r, I found that in the PlayerPawnTest file. I thought about it, played around with it a bit, and decided that I am too green with the SDK to know how to replicate that for my purposes, so I found a possible workaround. Buffs have a section where you can determine whether they work while underwater or not, so I figured I’d make my own buff and add it to a new shield item (to keep the mod clean). It (is at least supposed to) adds a 30 Oxygen/s buff, but I can’t seem to get it to work. I then tried just copying the GasMask buff (since it’s already configured to work when a specific item is worn) and I still couldn’t get it to work. I even tried adding a -10 Health/s buff to make sure it wasn’t just appearing like it doesn’t work, but that didn’t take effect either. So I’m kinda lost at the moment.
@AP_Studios Where were these volumeleft and volume enter nodes that you found? In the same PlayerPawnTest file?

they are the ones used for entering and exiting water - they can be found in the persistent level of the island map (or any of the maps i am sure)

You need to enable the buff using the equipped event on your shield item or the player will not get the buff. Take a look at PrimalItemArmor_GasMask graph to see how it’s done.

Pretty sure I did enable that, but regardless, I ran into a peculiar situation in the dev kit… I went into the test area, spawned a Tuso, and started riding it, and sure enough I was getting oxygen when at the surface of the water, which you would think would be good, but that was before I even spawned the shield and equipped it. It seems that in the dev kit riding a Tuso works just like it would any other aquatic mount, which makes testing whether or not my item works to be rather difficult. I’m going to have to cook it and hope for the best. Luckily the whole process doesn’t take TOO long.

It’s been a loooooooong time since I’ve actually played ark other than testing and certainly have never used a tuso but I’m 99.9% sure that’s a built in mechanic. I remember when when riding megalo’s and ithcy’s your oxygen regenerates when you surfaced

Man, I am so confused right now… on my server I have the custom Volcano map with the situation first mentioned in the OP where while riding a Tuso I lose oxygen even when at the surface. I went through all this hassle to try and make a mod, but in doing so found out that the aforementioned problem doesn’t happen in the dev kit’s test area, single player TheIsland without mods, single player TheVolcano without mods other than the map itself, or single player TheVolcano with all of my server’s mods. I have no idea what would cause this problem. If it’s because of some random .ini change I made to the server I’m going to be so ******… time to do some .ini spelunking to try and find out what the heck is causing this.