Download

FIXFOR PEOPLE GETTING BUILD ERROR Run.bat automation tool wildcard crashreport.exe or

I was getting this error or something similar “BUILD FAILED: RUN.BAT failed automation tool couldn’t find wildcard crashreport.exe”. So I searched around and found out that a few people on the forums also where having this problem and decided not to be lazy for once and actually just read the error report. After Looking carefully through the report I saw that it said failed to find files blah blah and everyone that had some type of answer was posting on the forums saying maybe try to reinstall visual studio and stuff similar to that but that’s silly as you can see crashreport.exe is missing from engine/binaries/Win64.

The problem is that for some strange reason visual studio doesn’t create this file when you do a normal build, and by that I mean when you just simply open the ue4.sln in visual studio then right clicking the ue4 tab on the right of the screen and selecting either rebuild or build, What you actually Must do is that you have to scroll in visual studio a little lower until you get to crashreport, then you must right click it and select “build” making sure that your settings are on “development editor and 64bit If that doesn’t work also try building it in just developmnt mode”

this will now fix the build error and you now should be able to build your projects. Make sure to check the win64 folder to see if crashreport.exe is now there after it has all been finished building in visual studio :)))) 72b2bd22db2d73b27527d1098499219e4df3a1e9.png

Also dont think this did anything but just incase, Before BULDING CRASHREPORT all the .exe in the engine folder and so on, I changed to run as admin by right clicking the .exe application, going to properties then compatability and checking the box “run this program as administrator” make sure to do this to the automationtool in the DotNET folder along with all the other .exe maybe it helped who knows lol, also I just figured out that in order to build your projects in 32bit mode you have to do the same thing As I previously stated before, execpt make sure to change the mode to shipping and change the 64bit mode into 32bit then right click crashreport and press build, thats all :slight_smile:

can you try a few periods and breaks in your sentences here please ? I find it very hard to understand and read.

yeah was rushing because I had work, ile fix it up