Download

Fixed framerate broken?

Hey!

Working on a project in with a group in Unreal 4.8

I would like to limit my framerate to 60 fps
But checking fixed framerate seem to make unreal send the “correct” delta time, but it does not limit the framerate.
This gives me a really accelerated feel, since it can render in about 300 fps. ( to say the least )

Could not find any resources about this, except for a bug posted on version 4.9
(We picked 4.8 to avoid these kinds of things)

I would like to not rewrite the physics model we use to account for variable timesteps, since this is a game jam type of thing to test a concept.

I have made sure that i dont force vsync off in my graphics card settings, so that shouldnt be the cause.

Is there something im doing wrong, or should just checking fixed framerate limit my fps and it is in fact a bug in the engine?

I’m having the same issue. It seems that the “Fixed Frame Rate” option locks DeltaSeconds from Tick, but not the actual frequency of Tick firing since it is called every frame. Consequently, I think that the acceleration you speak of is the result of physics calls getting piled on top of one another. For instance, say that your frame rate is locked at 30 and that you are sub-stepping to 60 frames for physics. If your physics calls are wrapped in Tick, and I think that they have to be to take advantage of sub-stepping, then your physics calls will be executed at 60 Hz. If, however, your frame rate spikes to 300 Hz, Tick will be calling physics manipulations five times faster than Physx can execute them since Physx was locked to 60Hz. Thus, Physx will have the additive force of five calls executing at once, which would result in forces five times higher than desired. I may be mistaken, but it would seem to be true from my experiments. My recommendation would be to set a “Smooth Frame Rate” with the min and max at your desired value and see if that helps. I think that the “Fixed Frame Rate” option isn’t quite wired in properly at this time. Good luck!