Fix this collision deflect feature of the CharacterMovement component?

Is there any way to turn this off, or maybe a work-around to fix it? It happens when the capsule hemisphere hits the underside of blocks when jumping, too. Really annoying having the player shoot off sideways. I understand how it might be desirable to some people, but it’s really messing up my project, which requires precision platforming. If there is any option I missed, or a work-around, please let me know!