Download

Fix the Linux UI, Context Menu, High DPI Sizing, Resizing

If you right-click near the bottom of the screen on Windows the context menu is properly shifted above the mouse cursor on Linux it opens below the cursor and is cut off.

On a 4k monitor with High DPI enabled the text is super small. The editor does not respect the zoom level configured in the system settings.

Although, windows that pop-up like the Add Class wizard, do behave properly.

When you resize the Editor window, the Content browser does not allow interaction after the resize.

There is also a crash when attempting to edit a Paper2D sprite.

Love UE4, but it is a challenge to work with on my high-end Linux laptop. I appreciate your hard work!

Hardware is a System76 Serval with a Geforce RTX 2080 and 4K built-in display running Ubuntu 18.04(PopOs).

Hey @CyrusVirothian - Would you fill out a report on your experience for our teams, please?

Does this have been fixed by now?
Is there any option to start Unreal with a fixed UI scaling value?

on starting the editor press
ctrl + shift + w
theres a little slider in the window that opens that lets you adjust the scail of the windows and fonts on 4k setting to arround 2.5 works for me

you need to do this everytime you start the editor , have not tried saving it as a system default yet though so not shure if its totaly fixed yet

think you also need to set the project quaity preset to scalable when you create it for that option to work

well as i have been having this issue and …
although it does appear to be resolved , your drivers/settings and monitor config can cause mayhem and upset it
not only does this issue affect UE5 editor it affects other apps

my experiances with the issue started with UE5

2 displays a dell 28" 4k (primary), and a sony 64" 4k tv (in original config desktop side by side extended)
using the nouveau drivers , my system respected the high dpi font settings , and did this automaticaly , and the fonts where all in sync , nothing too small nothing too big system wide ,
i now know that UE5 needs the official nvidia drivers not the nouveau ones , but it did get as far as starting the project selection menu (where yes the font sizes where tiny)

changing to the nvidia drivers is where the issues started for me

i swiched the primmary display to the sony tv , leaving the dell as a side screen for reading setup instructions as i went along , then found issues with other system apps
not supporting high dpi fonts , like google chrome not just ue5, ended up cnaging a lot of systems settings and app zooms manualy to get it about right , but still the super tiny font issues persisted

but by acident this morning i finaly found the solution it also seems to be the underlying cause of another issue i thought had been resolved by something else ,
mainly UE5 editor crashing on selecting an object , that i can now place as a nvidia driver monitor configuration issue
if the dell monitor is primary and the sony set to be a clone , no crash on UE5 and high dpi fonts are honerd system wide (no need for the ctrl+shift+w it works )
but if i set the sony monitor as primary back to supper small unreadable fonts and UE5 editor crashes on selecting object
far to say , other than i now have to manualy adjust back all the manual font changes i had to make (leaving most apps now having super large fonts) that the issue is not a UE5 issue , but a monitor config issue in the nvidea drivers !!!
as i tend to switch desktop configs arround on the fly depending on what im doing (given the sony tv is used sometimes for other than the pc ) it also explains why as if by magic the fonts all suddenly work , then later not type of random effect on newly started apps

hope this helps others with the same issue as its not always easy to have a different monitor on hand , but it dose point to it beeing down to the monitor profiles , given it may detect the sony and the modes correctly , but theres other stuff in the drivers list of monitor profiles , all i can say if your having this problem your monitor is not listed in them

sorry for the long post