Fix RHI/D3D11 crash

keep getting this error every 5-10 minutes, and its extremely frustrating to work like this! I cant even import anything without is crashing halfway through. It is also known as:

UE-4228 Crash due to D3D device being lost. (Error: 0x887A0006 - ‘HUNG’)

ive tried the -dx12 thing, tried forward renderer (fails to launch editor), and dont know how to do the grhi= 11 thing

What is your GPU?

Nvidia GTX 1080, I tried messing with Tdr reg settings but to no avail (maybe even made it a bit more unstable lol). The one thing I notice that happens right at the moment of/before the crash (which is leaking into my games now), is a GPU spike to 100 for an instant and then hits 0 losing leaving it crashed. Like my gpu loses connection with the rest of the situation idk

Oh now it doesnt show the crash dialog anymore, UE4editor just freezes so hard that even trying to end process directly through task manager gives access denied and I have restart my pc to get it go away from the process list or else it just keeps holding onto buncha gigs of memory :confused:

ive even tried DDU and reinstall gpu drivers

Doesn’t happen on an older PC with UE4.24 and Gtx1060, but on a newer machine with latest Windows 10 updated and Unreal 4.25, with a rtx2080ti… I see this crash a lot.

Oddly enough, a suggestion on the answerhub by DrAculaMD to keep UE4Editor in windowed (as in not maximized to fit screen), which kind of works lol. It has prolonged the crashes for a longer time, allowing me to work without it crashing every few minutes which is definitely weird but I guess a clue in the right direction. Just fyi though, I did reinstall my drivers from DDU clean install again, and am currently running an older version nvidia driver 382.64 which is from the clevo manufacturer site

I’m having this same problem. Ridiculously crashing every 10 minutes with this ** RHI/D3D11 crash. **I’ve tried all suggestions to fix it to no avail. When will this issue be resolved?