Download

FirstPersonCharacter - Not Working

Hi all,

I’ve done a bit of Googling to try and solve this but can’t seem to find a solution. I copied the FirstPersonCharacter Blueprint from the starter pack and pasted it into my project, fixed the compile errors (with more googling) but when I hit Play it just starts the game from the usual floating camera and not the FirstPersonCharacter camera?

Any ideas how I can solve this? I’m sure there’s a very simple solution!

Thanks,

Max

After copying the FirstPersonCharacter, you need to tell the engine to use it. The easiest way to do it is to edit the active game mode and set this character as the default Pawn class.
Or you could create a new Game mode BP (extended from GameMode), set the Pawn in it and then go and edit the Map&Modes option in Project settings. You can set your custom game mode as the active one there.

Thank you!

I actually had the default pawn class set I just needed to edit the Map & Modes game mode to the FirstPersonGameMode that I copied over earlier.