FirstPersonCharacter height / crouch

I’m trying to adjust the firstpersoncharacter height and add a crouch control in the blueprint but somehow neither of the settings work. Ive recompiled the blueprint, saved, and I get no error but when I press play it doesnt work.

any ideas what im doing wrong?

Have you enabled crouching in the default settings? :slight_smile:

Default settings? Where can I find those? I just googled default settings and crouch but no luck there.

Ah, sorry, wrong information. Click on your movement component and there you can find “can crouch” -> enable it. After that your upper setup will work :slight_smile:

Great! Found it thanks.

What about the height, have any idea why that isn’t working? :slight_smile:

The height of the capsule should be changing with the crouch/uncrouch function. When you want to change the height of the character, you will have to add an animation :slight_smile: